summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-22 03:34:43 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-22 03:34:43 -0500
commit6d9ddde00888d6edbfc9fd1fb56bb9b3709d1356 (patch)
treea58a06f33b6a6bd2ef25c271d4a0e6da3fdfe5d8
parent7499b4f620b052e7ced69972a0ad368cb648f2a7 (diff)
libremakepkg anounces error is from it.
-rwxr-xr-xlibremakepkg10
1 files changed, 6 insertions, 4 deletions
diff --git a/libremakepkg b/libremakepkg
index d98d94a..1b0776b 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -67,9 +67,9 @@ trap_exit() {
## Trap signals
# From makepkg
set -E
-trap 'trap_exit "TERM signal caught. Exiting..."' TERM HUP QUIT
-trap 'trap_exit "Aborted by user! Exiting..."' INT
-trap 'trap_exit "An unknown error has occurred. Exiting..."' ERR
+trap 'trap_exit "(libremakepkg): TERM signal caught. Exiting..."' TERM HUP QUIT
+trap 'trap_exit "(libremakepkg): Aborted by user! Exiting..."' INT
+trap 'trap_exit "(libremakepkg): An unknown error has occurred. Exiting..."' ERR
CLEAN_FIRST="n"
CLEAN_CACHE=""
@@ -108,6 +108,8 @@ pkgbuild-check-nonfree ||{
if [[ $? -eq 15 ]]; then # other errors mean fail, not nonfree
error "PKGBUILD contains non-free issues"
exit 15
+ else
+ true
fi
}
@@ -119,7 +121,7 @@ fi
if [ "${CLEAN_FIRST}" = y ]; then
msg "Cleaning ..."
- cp "/etc/libretools.d/cleansystem" "${CHROOTDIR}/${CHROOTNAME}/root"
+ cp "/etc/libretools.d/cleansystem" "${CHROOTDIR}/${CHROOTNAME}/root/"
(cat <<EOF
#!/bin/bash
export LANG=C