summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-05-30 12:44:41 -0500
committerJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-05-30 12:44:41 -0500
commitfd87ecf1e20dadc37e6ffd84e120f63711868fc2 (patch)
treea22b2d290e0dfd70363cafc3982eee3454f679e9
parentfe983eea4b3cedbdd3ca33b05162340b2a4a4e7a (diff)
* Exit build cycle when end
-rwxr-xr-xfullpkg-ng2
1 files changed, 1 insertions, 1 deletions
diff --git a/fullpkg-ng b/fullpkg-ng
index 485ba90..620c625 100755
--- a/fullpkg-ng
+++ b/fullpkg-ng
@@ -179,7 +179,7 @@ function find_deps {
function _pkg_build () {
pushd ${build_dir} > /dev/null
build_packages=$(sort -gr $buildorder | cut -d: -f2)
- while [ ${#build_packages[@]} -ge 1 ]; do
+ while [ ${#build_packages[@]} -gt 1 ]; do
build_packages=$(sort -gr $buildorder | cut -d: -f2)
pushd $build_dir/${build_packages[0]} > /dev/null
source PKGBUILD