summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-27 21:00:12 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-27 21:00:12 -0300
commit1a60b54ff583a39e1069dcd527c347f23bbc2b5a (patch)
tree4a8ebf6518e2d12bfc9df632a534878bfd70287f
parent7310a3f4243b9fafb3f01d5430fa96575bfd0819 (diff)
Several fixes
-rwxr-xr-xaur7
-rwxr-xr-xlibrerepkg2
2 files changed, 8 insertions, 1 deletions
diff --git a/aur b/aur
index a7408b7..7c2860b 100755
--- a/aur
+++ b/aur
@@ -37,6 +37,11 @@ done
missing_deps=()
for _pkg in ${@}; do
+
+# Remove the version
+# TODO check downloaded PKGBUILD version
+ _pkg="${_pkg%%[<>=]*}"
+
msg "Downloading $_pkg..."
wget -O - -q http://aur.archlinux.org/packages/$_pkg/$_pkg.tar.gz | \
tar xzf - >/dev/null 2>&1
@@ -75,6 +80,8 @@ for _pkg in ${@}; do
if ! find ${ABSROOT} -maxdepth 2 -type d -name "$_dep" | egrep "*" >/dev/null ; then
missing_deps=(${missing_deps} $_dep)
fi
+ else
+ msg2 "$_dep is on repos"
fi
done
diff --git a/librerepkg b/librerepkg
index 5125023..6232406 100755
--- a/librerepkg
+++ b/librerepkg
@@ -58,6 +58,6 @@ msg2 "Updating md5sums"
makepkg -gp rePKGBUILD >> rePKGBUILD
msg "Repackaging using makepkg"
-makepkg -Lcp rePKGBUILD
+makepkg -Lcdp rePKGBUILD
stdnull popd ${tempdir}