summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-10-29 16:00:09 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-10-29 16:00:09 -0300
commitbb356fb2f9de3991e4dfe04409d27d348f69ac66 (patch)
tree82dba036948c6f971935eb99fc2583585334f46c
parent7389eee3207cf2e06b6392cac3cdbe622d284df7 (diff)
parentaae1b41ea2644da980a1645ee9e27dfe7560ec2e (diff)
Merge branch 'master' into tokyo
Conflicts: update-cleansystem
-rwxr-xr-xlibremkchroot13
-rwxr-xr-xtoru-info28
-rwxr-xr-xupdate-cleansystem43
3 files changed, 71 insertions, 13 deletions
diff --git a/libremkchroot b/libremkchroot
index c1f2072..b576209 100755
--- a/libremkchroot
+++ b/libremkchroot
@@ -2,7 +2,7 @@
# LibreMkChroot
# Creates a chroot
-# Copyright 2011 Luke Shumaker
+# Copyright 2011, 2012 Luke Shumaker
# ---------- GNU General Public License 3 ----------
@@ -27,10 +27,7 @@ if [ -e "$XDG_CONFIG_HOME/libretools/libretools.conf" ]; then
source "$XDG_CONFIG_HOME/libretools/libretools.conf"
fi
-#CHROOTNAME="${CHROOT:-${SUDO_USER:-root}}"
-
cmd=${0##*/}
-
function usage {
echo "Usage: $cmd [OPTIONS]"
echo 'This script will create a chroot to build packages in.'
@@ -47,12 +44,12 @@ function usage {
echo ' -M <file> Location of makepkg config file.'
}
-mkchroot_args='';
+mkchroot_args=();
while getopts 'hfd:c:C:M:' arg; do
case "$arg" in
h) usage; exit 0 ;;
- f) mkchroot_args="$mkchroot_args -$arg" ;;
- c|C|M) mkchroot_args="$mkchroot_args -$arg $OPTARG" ;;
+ f) mkchroot_args+=("-$arg");;
+ c|C|M) mkchroot_args+=("-$arg" "$OPTARG");;
d) CHROOTDIR=$OPTARG ;;
?) usage; exit 1 ;;
esac
@@ -64,4 +61,4 @@ if (( EUID )); then
fi
mkdir -p "${CHROOTDIR}"
-xargs -d'\n' mkarchroot $mkchroot_args "${CHROOTDIR}/root" < /etc/libretools.d/cleansystem
+xargs -d'\n' mkarchroot "${mkchroot_args[@]}" "${CHROOTDIR}/root" < /etc/libretools.d/cleansystem
diff --git a/toru-info b/toru-info
new file mode 100755
index 0000000..523f682
--- /dev/null
+++ b/toru-info
@@ -0,0 +1,28 @@
+#!/bin/bash
+# Prints info about a given pkgname
+source /etc/libretools.conf
+
+for _pkg in $@; do
+ _pkgbuild="$(toru-where $_pkg)"
+
+ if [ -f "$_pkgbuild/PKGBUILD" ]; then
+ source "$_pkgbuild/PKGBUILD" 2>/dev/null || {
+ warning "Errors on %s" $_pkg
+ continue
+ }
+
+ deps="${depends[@]} ${makedepends[@]} ${checkdepends[@]}"
+ repo="$(basename $(dirname "$_pkgbuild"))"
+
+ unset build package depends makedepends checkdepends optdepends source md5sums
+
+ msg "%s/%s %s-%s" $repo $_pkg $pkgver $pkgrel
+ msg2 "$pkgdesc"
+ msg2 "$url"
+ msg2 "Depends: ${deps}"
+ else
+ warning "%s doesn't exist" $_pkg
+ fi
+
+ unset pkgname pkgver pkgrel pkgdesc url
+done
diff --git a/update-cleansystem b/update-cleansystem
index 98eb0dc..53d21d9 100755
--- a/update-cleansystem
+++ b/update-cleansystem
@@ -1,13 +1,46 @@
#!/bin/bash
# Updates the cleansystem file
-# Creates a fake Parabola root and prints all packages installable from base
-# and base-devel plus extras
+# Creates a fake Parabola root and writes to cleansystem all
+# packages installable from base and base-devel plus extras.
set -e
+# Copyright 2012 Nicolás Reynolds, Luke Shumaker
-if [ ! -w / ]; then
- echo "Run as root."
- exit 1
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+source /etc/libretools.conf
+
+cleansystem=/etc/libretools.d/cleansystem
+
+cmd=${0##*/}
+usage() {
+ echo "Usage: $cmd [<EXTRA_PACKAGES>]"
+ echo " $cmd -h"
+ echo "Creates a fake Parabola root and writes to \`$cleansystem' all"
+ echo "packages installable from base and base-devel plus extras."
+ echo ''
+ echo 'Options:'
+ echo ' -h Show this message'
+}
+
+if [ "$1" == '-h' ]; then
+ usage
+ exit 0
fi
# Maintain a clean database in the system