summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-12 17:18:14 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-12 17:18:14 -0500
commit487602793c43a5858b734fde4bbb8d0fdb80e96b (patch)
tree43dc541efbdbd87e87e5a555495793db1a9a798d
parent027db84b180a16a17a9414a88e7a35a7669983fa (diff)
libretools.conf: organize into sections
-rw-r--r--src/libretools.conf49
1 files changed, 36 insertions, 13 deletions
diff --git a/src/libretools.conf b/src/libretools.conf
index 70d2eca..631ca89 100644
--- a/src/libretools.conf
+++ b/src/libretools.conf
@@ -1,24 +1,33 @@
#!/bin/bash
+################################################################################
+# misc #
+################################################################################
+
## Blacklist URL
+## Used by `pkgbuild-check-nonfree`
BLACKLIST=http://repo.parabolagnulinux.org/docs/blacklist.txt
-# Diff tool (vimdiff, gvimdiff, meld, etc)
+## Diff tool (vimdiff, gvimdiff, meld, etc)
+## Used by `aur`, `diff-unfree`
DIFFTOOL=`which vimdiff gvimdiff meld colordiff 2>/dev/null|sed 's/\s.*//'`
-# The dir where you work on
-WORKDIR=/home/$USER/packages
-# The repos you'll be packaging for
-#
+## The repos you'll be packaging for
+## Used by `toru`, `createworkdir`, `prfullpkg`
# Tip: As early repos take precedence on $REPOS loops, you can use this as
# inverted order of precedence. Put testing repos first so fullpkg find new
# PKGBUILDs first, for instance. Toru-path uses reverse order to enforce repo
# precedence on the path cache (the last path added replaces the rest)
REPOS=('core' 'libre' 'extra' 'community' 'libre-testing' 'social' 'sugar' 'pcr' 'java')
-# The architectures
+## The architectures
+## Used by `librestage`
ARCHES=('i686' 'x86_64' 'mips64el' 'any')
+################################################################################
+# chroot #
+################################################################################
+
## The directory where the chroots are stored
CHROOTDIR=/home/chroot
## Extra packages to have installed on the chroot (besides base base-devel and sudo)
@@ -27,7 +36,19 @@ CHROOTEXTRAPKG=(distcc ccache tsocks libretools)
## do NOT set it to 'root'
CHROOT=default
-## Parabola hostname (should be the same used on ssh_config
+################################################################################
+# abslibre #
+################################################################################
+
+# The dir where you work on
+WORKDIR=/home/$USER/packages
+
+## Package signing
+# Leave commented to disable signing
+#SIGEXT=".sig"
+#SIGID="0xYOURID"
+
+## Parabola hostname
PARABOLAHOST=parabola
## Assumes something similar in your .ssh/config:
@@ -51,6 +72,10 @@ ABSLIBREGIT=http://projects.parabolagnulinux.org/abslibre.git
COMMITCMD=git
#COMMITCMD=hg
+################################################################################
+# fullpkg #
+################################################################################
+
## Uncomment one of those or make one of your choice
# Normal fullpkg
FULLBUILDCMD="sudo libremakepkg -cuN"
@@ -71,15 +96,13 @@ HOOKPRERELEASE="ssh -fN parabola"
# succesfully
# HOOKLOCALRELEASE=""
-## Toru
+################################################################################
+# toru #
+################################################################################
+
# Section for toru's vars
TORUPATH=/var/lib/libretools/toru
-## Package signing
-# Leave commented to disable signing
-#SIGEXT=".sig"
-#SIGID="0xYOURID"
-
################################################################################
# This probably shouldn't be in a .conf file... #
################################################################################