summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@parabola.nu>2024-02-21 18:54:00 -0700
committerLuke T. Shumaker <lukeshu@parabola.nu>2024-02-21 19:27:19 -0700
commit2242ff2968afbf42ffcbe1aec228a92d6db25e1c (patch)
tree1ec65e233f33b2e894e88d2d361c463a32c6ebcc
parent497656ccafef59e009525b663f940d7d97f8906d (diff)
fix: librefetch: Don't include .INSTALL
-rwxr-xr-xsrc/librefetch/librefetch1
-rw-r--r--src/librefetch/librefetch.8.ronn1
-rw-r--r--test/fixtures/librefetch/PKGBUILD-mksource1
-rw-r--r--test/fixtures/librefetch/testpkg.install5
4 files changed, 8 insertions, 0 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 9b04837..0a1bb70 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -347,6 +347,7 @@ checkdepends=() ; unset "checkdepends_${CARCH}"
makedepends=("${mkdepends[@]}") ; unset "makedepends_${CARCH}"
backup=()
+unset install
####
# See packaging_options in the makepkg source
diff --git a/src/librefetch/librefetch.8.ronn b/src/librefetch/librefetch.8.ronn
index 63dfae9..b73db3b 100644
--- a/src/librefetch/librefetch.8.ronn
+++ b/src/librefetch/librefetch.8.ronn
@@ -143,6 +143,7 @@ Following is a table of the translations.
makedepends = mkdepends
*_$CARCH = <unset>
backup = <empty>
+ install = <unset>
Functions
prepare() { :; }
build() { mksource; }
diff --git a/test/fixtures/librefetch/PKGBUILD-mksource b/test/fixtures/librefetch/PKGBUILD-mksource
index 74489de..67f6bc3 100644
--- a/test/fixtures/librefetch/PKGBUILD-mksource
+++ b/test/fixtures/librefetch/PKGBUILD-mksource
@@ -5,6 +5,7 @@ pkgdesc=foo
arch=(any)
source=("libre://$pkgname-$pkgver.tar.gz"{,.sig})
backup=(etc/testpkg.conf)
+install=testpkg.install
mksource() {
mkdir "$srcdir/bar"
diff --git a/test/fixtures/librefetch/testpkg.install b/test/fixtures/librefetch/testpkg.install
new file mode 100644
index 0000000..8ff0e47
--- /dev/null
+++ b/test/fixtures/librefetch/testpkg.install
@@ -0,0 +1,5 @@
+#!/hint/bash
+
+post_instal() {
+ true
+}