summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-29 21:34:27 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:40:10 -0600
commitb80db9fe6e1b435c294885394c9d4eb804fd6750 (patch)
tree529e76d1e25ef5f3b99e1a830bb6a15efc6220bf
parentc0502e7974dd82747fe289c060ff6b1883f87cd5 (diff)
aur: don't support not diffing a package if there is diffing to be done
-rwxr-xr-xsrc/aur13
1 files changed, 4 insertions, 9 deletions
diff --git a/src/aur b/src/aur
index b325974..e951e0e 100755
--- a/src/aur
+++ b/src/aur
@@ -59,15 +59,10 @@ main() {
if [[ -f "${_pkg}/PKGBUILD" ]]; then
warning "${_pkg} already existed."
- # Check if we want to diff
- if [[ -z "${DIFFTOOL}" ]]; then
- continue
- else
- # Store our copy of the PKGBUILD dir
- _diff="${PWD}/${_pkg}"
- pushd $(mktemp --tmpdir -d ${_pkg}.XXXX) &>/dev/null
- msg2 "Downloading PKGBUILD into ${PWD} for diff"
- fi
+ # Store our copy of the PKGBUILD dir
+ _diff="${PWD}/${_pkg}"
+ pushd $(mktemp --tmpdir -d ${_pkg}.XXXX) &>/dev/null
+ msg2 "Downloading PKGBUILD into ${PWD} for diff"
fi
msg "Downloading $_pkg..."