summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-08-06 16:40:09 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-08-06 16:40:09 -0400
commit7a16e913507bf49d8fafdacfaf859489727151e1 (patch)
treea6b83e36b08a9682cc99b1886a577e1897c20099
parent6faf57c73c9bf035744080805048121b6a49aa5f (diff)
chcleanup: Ignore depends of split packages, just look at pkgbasev20180806
-rw-r--r--src/chroot-tools/chcleanup.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/chroot-tools/chcleanup.in b/src/chroot-tools/chcleanup.in
index e311d4b..e5e7668 100644
--- a/src/chroot-tools/chcleanup.in
+++ b/src/chroot-tools/chcleanup.in
@@ -61,7 +61,7 @@ if [[ -f ./PKGBUILD ]]; then
sudo -u "#$(stat -c %u -- ./PKGBUILD)" sh -c 'makepkg --printsrcinfo > .SRCINFO'
fi
CARCH="$(. /etc/makepkg.conf; printf '%s' "$CARCH")"
- mapfile -t DEPENDS < <(sed -nE "s/^\\s+(|make|check)depends(|_${CARCH}) = //p" < .SRCINFO)
+ mapfile -t DEPENDS < <(sed -nE -e "s/^\\s+(|make|check)depends(|_${CARCH}) = //p" -e '/^\s*pkgname/q' < .SRCINFO)
else
DEPENDS=()
fi