summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-01 15:24:33 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 20:01:04 -0600
commitba54f82cf53d0155c6756af60a012f8032744945 (patch)
tree147847acce6e0c40ce1e965b1a4f831954718eb0
parent9ec5166e11fbaa33156f47df0b98a6419e0a339a (diff)
Fix tests for networks that have a host on them named "phony".
I was using "http://phony" as a URL that would fail to be retrieved. Well, I'm currently on a network (Chick-fil-A Wifi) that returns a web search for unknown hostnames. So, now I use "phony://example.com".
-rw-r--r--test/lib-blacklist-test.sh4
-rw-r--r--test/pkgbuild-check-nonfree-test.sh2
2 files changed, 3 insertions, 3 deletions
diff --git a/test/lib-blacklist-test.sh b/test/lib-blacklist-test.sh
index 94f5b27..3ac8e70 100644
--- a/test/lib-blacklist-test.sh
+++ b/test/lib-blacklist-test.sh
@@ -46,7 +46,7 @@ it_works_with_colons_in_reason() {
it_fails_update_when_there_is_no_blacklist_or_network() {
mkdir -p $XDG_CONFIG_HOME/libretools
- echo "BLACKLIST='http://phony'" >$XDG_CONFIG_HOME/libretools/libretools.conf
+ echo "BLACKLIST='phony://example.com'" >$XDG_CONFIG_HOME/libretools/libretools.conf
libreblacklist update >$tmpdir/stdout 2>$tmpdir/stderr || stat=$?
@@ -57,7 +57,7 @@ it_fails_update_when_there_is_no_blacklist_or_network() {
it_fails_cat_when_there_is_no_blacklist_or_network() {
mkdir -p $XDG_CONFIG_HOME/libretools
- echo "BLACKLIST='http://phony'" >$XDG_CONFIG_HOME/libretools/libretools.conf
+ echo "BLACKLIST='phony://example.com'" >$XDG_CONFIG_HOME/libretools/libretools.conf
libreblacklist cat >$tmpdir/stdout 2>$tmpdir/stderr || stat=$?
diff --git a/test/pkgbuild-check-nonfree-test.sh b/test/pkgbuild-check-nonfree-test.sh
index 5ddd341..e9c37bf 100644
--- a/test/pkgbuild-check-nonfree-test.sh
+++ b/test/pkgbuild-check-nonfree-test.sh
@@ -55,7 +55,7 @@ it_fails_with_15_for_nonfree_depend() {
it_fails_when_there_is_no_blacklist() {
mkdir -p $XDG_CONFIG_HOME/libretools
- echo "BLACKLIST='http://phony'" >$XDG_CONFIG_HOME/libretools/libretools.conf
+ echo "BLACKLIST='phony://example.com'" >$XDG_CONFIG_HOME/libretools/libretools.conf
rm $XDG_CACHE_HOME/libretools/blacklist.txt
$pcn $pcn.d/PKGBUILD.free >$tmpdir/stdout 2>$tmpdir/stderr || stat=$?