summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-02-02 20:18:20 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-02-02 20:18:20 -0500
commitd7dcce53396d32c090e1e175c9c606a78f5cb3d6 (patch)
tree1bcca493203fd82c2c05f1d546c16e9444b80a38
parent1a7621e6e3ca4ad7c132d1b9d4f7d5dc67fc1a32 (diff)
mkarchroot: don't let the environment affect pacstrap
-rw-r--r--src/chroot-tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index d08775e..4ecff51 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -34,7 +34,7 @@ makechrootpkg.sh: %: %.ugly Makefile
mkarchroot: mkarchroot.in Makefile
@echo '< $< M4_EDIT | SED > $@'
- @<'$<' $(edit) | sed 's|arch-nspawn|$$(librelib chroot/&)|' >'$@' || { rm -f -- '$@'; false; }
+ @<'$<' $(edit) | sed -e 's|arch-nspawn|$$(librelib chroot/&)|' -e 's/pacstrap/env -i &/' >'$@' || { rm -f -- '$@'; false; }
@echo 'CHMOD $<'; chmod 755 "$@" || { rm -f -- '$@'; false; }
archroot: %: %.in Makefile