summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-09-22 00:20:15 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-09-22 00:20:15 -0300
commitf49a63724e56c11c5ee89561f573fff1b1d56506 (patch)
treee6fa06ed9f90a921cb8983da5da2a89510d86b49
parentb3b52d5c4a3cbcdeb505b099230107b830290e8e (diff)
Skip already built packagesv20120924
-rwxr-xr-xtreepkg4
1 files changed, 4 insertions, 0 deletions
diff --git a/treepkg b/treepkg
index 00ec0e0..8a243e4 100755
--- a/treepkg
+++ b/treepkg
@@ -194,6 +194,8 @@ if [ ${DEPTH} -eq 0 ]; then
for _pkg in $(ls -r "${BUILDDIR}"); do
# Ignore if there's no PKGBUILD
if [ ! -f "${BUILDDIR}/${_pkg}/PKGBUILD" ]; then continue; fi
+# Skip if already built (faster than calling is_build again)
+ if [ -f built_ok ]; then continue; fi
${VERBOSE} && msg "Building ${_pkg/_/ }" || true
@@ -204,6 +206,8 @@ if [ ${DEPTH} -eq 0 ]; then
${FULLBUILDCMD}
# Run local release hook with $1 = $repo
${HOOKLOCALRELEASE} $(egrep ";${_pkg#*_};" "${BUILDORDER}" | cut -d';' -f6)
+
+ touch built_ok
popd >/dev/null
done