summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-03-26 17:50:36 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-03-26 17:50:36 -0400
commit5691f389185d30211214a68346b74452e3390224 (patch)
tree51959c5b0c063232b37b2e8ca0f875fe89d3538b
parentf15c69a9afc489b892ab1382aeb1c2e7ff67fd06 (diff)
Makefile: Fix .git files being in $(libretools.src.exec)v20180326
-rw-r--r--build-aux/Makefile.once.head/00-libretools.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/build-aux/Makefile.once.head/00-libretools.mk b/build-aux/Makefile.once.head/00-libretools.mk
index 832649d..f3462d5 100644
--- a/build-aux/Makefile.once.head/00-libretools.mk
+++ b/build-aux/Makefile.once.head/00-libretools.mk
@@ -100,7 +100,7 @@ libretools.pofmt = msguniq -Fi --to-code=UTF-8
# It's easy to think of these as "each" variables, but because they
# will be evaluated on demand, only files.src.src needs to be "each".
libretools.src.git = $(files.src.src)
-libretools.src.exec = $(patsubst $(srcdir)/%,%,$(shell find $(addprefix $(srcdir)/,$(libretools.src.git)) -executable 2>/dev/null))
+libretools.src.exec = $(patsubst $(srcdir)/%,%,$(shell find $(addprefix $(srcdir)/,$(libretools.src.git)) -maxdepth 0 -executable -type f 2>/dev/null))
libretools.src.conf = $(filter %.conf,$(libretools.src.git))
libretools.src.sh = $(filter %.sh ,$(libretools.src.git))
libretools.src.ronn = $(filter %.ronn,$(libretools.src.git))