summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2011-08-15 15:35:50 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2011-08-15 15:35:50 -0300
commit2c4723526c438253a3a55bc80fff08b3e42fd3e1 (patch)
tree5886d058a8764707b92c5b04dd0f958bf598a762
parent6a42b684dea1611f70f78199bf356888a6978a04 (diff)
parentef7eee8a30c74760186a73e536397f8ee740a8fd (diff)
Merge branch 'master' of ssh://gparabola/libretools
-rwxr-xr-xlibrechroot4
-rwxr-xr-xlibremakepkg12
-rwxr-xr-xlibrerepkg2
-rw-r--r--libretools.conf11
4 files changed, 13 insertions, 16 deletions
diff --git a/librechroot b/librechroot
index 8071ca9..d3e02f1 100755
--- a/librechroot
+++ b/librechroot
@@ -27,7 +27,7 @@ function usage {
echo "Usage: $0 chrootname"
echo "Change to a chroot in $CHROOTDIR. Use it as root."
echo
- echo "Default chroot name: $CHCOPY"
+ echo "Default chroot name: $CHROOT"
}
while getopts 'h' arg; do
@@ -45,7 +45,7 @@ custom_config=${XDG_CONFIG_HOME}/libretools/libretools.conf
[[ -e ${custom_config} ]] && source ${custom_config}
# Enter the chroot copy by default
-chrootname=${1:-$CHCOPY}
+chrootname=${1:-$CHROOT}
CACHEDIR=${CACHEDIR:-/var/cache/pacman/pkg}
[[ ! -d ${CHROOTDIR}/${chrootname} ]] && {
diff --git a/libremakepkg b/libremakepkg
index f9f7316..ef72526 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -33,7 +33,7 @@ function usage { # Display message and exit
echo ' -h show this message.'
echo ' -c cleans the chroot before building.'
echo ' -u updates the chroot before building.'
- echo ' -n use this dir instead of "${CHCOPY}".'
+ echo ' -n use this dir instead of "${CHROOT}".'
echo ' -M <--arg> passes long args to makepkg, use it as many times as needed.'
echo
exit 1
@@ -43,9 +43,9 @@ function buildenv { # Mounts *DEST from makepkg.conf
msg "Building env"
for mp in ${SRCDEST} ${PKGDEST} ${SRCPKGDEST}; do
- msg2 "binding ${mp} to ${CHROOTDIR}/${CHCOPY}${mp}"
- mkdir -p "${CHROOTDIR}/${CHCOPY}${mp}"
- mount -o bind ${mp} "${CHROOTDIR}/${CHCOPY}${mp}" || exit 1
+ msg2 "binding ${mp} to ${CHROOTDIR}/${CHROOT}${mp}"
+ mkdir -p "${CHROOTDIR}/${CHROOT}${mp}"
+ mount -o bind ${mp} "${CHROOTDIR}/${CHROOT}${mp}" || exit 1
done
}
@@ -91,7 +91,7 @@ function trap_exit { # End inmediately but print a useful message
# args are treated as part of the message
for mp in ${SRCDEST} ${PKGDEST} ${SRCPKGDEST}; do
- umount "${CHROOTDIR}/${CHCOPY}${mp}"
+ umount "${CHROOTDIR}/${CHROOT}${mp}"
done
copy_log
@@ -111,7 +111,7 @@ CLEAN_FIRST="n"
CLEAN_CACHE=""
UPDATE_FIRST="n"
USE_LOG='n'
-CHROOTNAME=${CHCOPY}
+CHROOTNAME=${CHROOT}
MAKEPKG_ARGS=""
libremakepkgargs='hcuUn:I:M:' # libremakepkg own args
diff --git a/librerepkg b/librerepkg
index 90e68ae..647a7c0 100755
--- a/librerepkg
+++ b/librerepkg
@@ -58,6 +58,6 @@ msg2 "Updating md5sums"
makepkg -gp rePKGBUILD >> rePKGBUILD
msg "Repackaging using makepkg"
-makepkg -Lcdp rePKGBUILD
+makepkg -Lcdp rePKGBUILD $@
stdnull popd ${tempdir}
diff --git a/libretools.conf b/libretools.conf
index 9cd1c9a..c6a8245 100644
--- a/libretools.conf
+++ b/libretools.conf
@@ -18,17 +18,14 @@ ARCHES=('i686' 'x86_64' 'mips64el' 'any')
## The directory where the chroots are stored
CHROOTDIR=/home/chroot
-## The main chroot
+## The working chroot
+# A chroot is useful to build packages isolated from the current system and avoid
+# unwanted (as in not in dependencies) automatic library linking
CHROOT=root
-## The working copy
-CHCOPY=copy
## Obtains CacheDir from pacman.conf
CACHEDIR=`grep "^#\?CacheDir" /etc/pacman.conf | cut -d'=' -f2`
-## Directory where you store PKGBUILD patches
-PATCHDIR=${WORKDIR}/abslibre/patches
-
## Parabola hostname (should be the same used on ssh_config
PARABOLAHOST=parabola
@@ -65,7 +62,7 @@ TORUPATH=/var/lib/libretools/toru
# Checks if vars aren't empty
-for VAR in CHROOTDIR CHROOT CHCOPY CACHEDIR PARABOLAHOST LIBREDESTDIR \
+for VAR in CHROOTDIR CHROOT CACHEDIR PARABOLAHOST LIBREDESTDIR \
BLACKLIST WORKDIR PATCHDIR REPOS ARCHES ABSLIBREGIT \
COMMITCMD DIFFTOOL FULLBUILDCMD; do