summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-03-25 21:03:02 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-03-25 21:03:02 -0400
commitbcdde66dc12bb7ebd8d6cf4833115b719b24f2e1 (patch)
tree45b1a57abadd02ed27eb1d5d258fd36cea40f60d
parent222856031fbbf314e8e47db414225756a9c6fba2 (diff)
touch up the librefetch(8) man page
-rw-r--r--src/librefetch/librefetch.8.ronn59
1 files changed, 30 insertions, 29 deletions
diff --git a/src/librefetch/librefetch.8.ronn b/src/librefetch/librefetch.8.ronn
index 7d2dfb3..895d063 100644
--- a/src/librefetch/librefetch.8.ronn
+++ b/src/librefetch/librefetch.8.ronn
@@ -11,7 +11,7 @@ librefetch(8) -- downloads or creates a liberated source tarball
`librefetch` is a program to streamline creation of custom source
tarballs for `PKGBUILD(5)` files.
-If a URL mentioned in the `source` array in a `PKGUILD` is in a
+If a URL mentioned in the <source> array in a `PKGUILD` is in a
location that Parabola uploads "custom" source tarballs (or configured
locations), and no file is at that URL, librefetch will automatically
create it for you.
@@ -52,16 +52,16 @@ fails, it may choose to try `create` mode.
## DOWNLOAD MODE
If <SOURCE-URL> begins with the string `libre://`, it is replaced with
-the first value in `MIRRORS`, as configured in `librefetch.conf(5)`;
+the first value in <MIRRORS>, as configured in `librefetch.conf(5)`;
this is for compatability with PKGBUILDs that used a previous version
of librefetch.
-It uses `DOWNLOADER`, as configured in `librefetch.conf` to attempt to
+It uses <DOWNLOADER>, as configured in `librefetch.conf` to attempt to
download the source tarball from that URL. If that fails, and
following conditions are met, it proceeds to `create` mode:
* The `-D` flag has not been specified to inhibit `create` mode.
- * The `<source-url>` begins with one of the values in `MIRRORS`.
+ * The <SOURCE-URL> begins with one of the values in <MIRRORS>.
The latter requirement allows librefetch to be used as a generic
HTTP(S) download agent, that can automatically create files from
@@ -70,13 +70,13 @@ whitelisted locations.
## CREATE MODE
The principle of `create` mode is that a special `PKGBUILD(5)`, called
-a `SRCBUILD(5)`, installs source files to `$pkgdir`, and the resulting
-"package" is then used as a source tarball. The `SRCBUILD` exists in
-the same directory as the `PKGBUILD`. It can be created manually, or
-generated on-the-fly from the `PKGBUILD`. Extra steps are taken to
-ensure that as long as the same directory contents go in, an identical
-tarball will come out--the checksum of the file should not change
-based on when it is built or who builds it.
+`SRCBUILD(5)`, that installs source files to <$pkgdir>, and the
+resulting "package" is then used as a source tarball. The `SRCBUILD`
+exists in the same directory as the `PKGBUILD`. It can be created
+manually, or generated on-the-fly from the `PKGBUILD`. Extra steps
+are taken to ensure that as long as the same directory contents go in,
+an identical tarball will come out--the checksum of the file should
+not change based on when it is built or who builds it.
The `SRCBUILD` is either created, or sanitized if it already exists,
then fed to a modified version of `makepkg(8)`.
@@ -98,14 +98,14 @@ file can be printed instead of executed with `print` mode.
### PRE-EXISTING SRCBUILD
The use of `SRCBUILD` files pre-dates `librefetch`. By convention,
-they set `PKGDEST` and `PKGEXT` in `package()` in order to modify the
+they set <PKGDEST> and <PKGEXT> in `package()` in order to modify the
behavior of `makepkg`. Because a modified version of `makepkg` is
used, this interferes with the correct behavior. To compensate for
this, lines containing "`PKGDEST=`" or "`PKGEXT=`" are deleted from
the `SRCBUILD`.
The general idea is that `build()` makes any modifications to the
-source, then `package()` copies it from `$srcdir` to `$pkgdir`.
+source, then `package()` copies it from <$srcdir> to <$pkgdir>.
### SRCBUILD FROM PKGBUILD
@@ -131,31 +131,32 @@ Following is a table of the translations.
makedepends = mkdepends
Functions
prepare() { :; }
- build() { mksource; }
- check() { :; }
+ build() { mksource; }
+ check() { :; }
package() { cp -a "$srcdir"/*/ "$pkgdir/"; }
The `mksource()` function does not need to be defined. If it isn't
defined, then no transformations will be made to the source between it
-being extracted to `$srcdir` and copied to `$pkgdir`.
+being extracted to <$srcdir> and copied to <$pkgdir>.
In summary:
- * Set `mksource=()` and `mkmd5sums=(`) to act as `source=(`) and
- `md5sums=()`
+ * Set <mksource=()> and <mkmd5sums=()> to act as <source=()> and
+ <md5sums=()>, respectively.
* Declare a `mksource()` function to make modifications to the
source, if nescessary.
Other changes:
- * `pkgname` is set to `pkgbase`, or the first element of the
- `pkgname` array.
- * `options=()` is set have `makepkg` avoid making changes to
- `$pkgdir`. The exact change is:
+ * <pkgname> is set to <pkgbase>, or the first element of the
+ <pkgname> array (the effect is that split packaging is turnes
+ off).
+ * <options=()> is set have `makepkg` avoid making changes to
+ <$pkgdir>. The exact change is:
options=(!strip docs libtool staticlibs emptydirs !zipman purge !upx)
- * `PURGE_TARGETS=()` has vcs directories added to it:
+ * <PURGE_TARGETS=()> has vcs directories added to it:
PURGE_TARGETS=(.bzr/ .cvs/ .git/ .hg/ .svn/ .makepkg/)
@@ -163,18 +164,18 @@ Other changes:
The following modifications are made to makepkg:
- * Allow us to manipulate the output file (`$pkg_file`)
- * Do not include metadata in the output file (`${comp_files[@]}`)
+ * Allow us to manipulate the output file (<$pkg_file>)
+ * Do not include metadata in the output file (<${comp_files[@]}>)
* Force 'ustar' tar format, don't allow it to upgrade to 'pax' to
store extended file attributes.
* Don't symlink the resulting file into the current directory.
- * `PURGE_TARGETS` interprets an item as a directory if it ends with a
+ * <PURGE_TARGETS> interprets an item as a directory if it ends with a
slash ("/").
- * Timestamps in `$pkgdir` are reset to "1990-01-01 0:0:0 +0", so that
+ * Timestamps in <$pkgdir> are reset to "1990-01-01 0:0:0 +0", so that
the resulting tarball will be the same, regardless of when it was
created.
- * append `-libre` to `$srcdir`
- * append `-libre` to `$pkgbasedir` (which becomes `$pkgdir`)
+ * append `-libre` to <$srcdir>
+ * append `-libre` to <$pkgbasedir> (which becomes <$pkgdir>)
* Don't check if the package has already been built.
## CONFIGURATION