summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua I. Haase H. (xihh) <hahj87@gmail.com>2012-06-29 00:00:47 -0500
committerJoshua I. Haase H. (xihh) <hahj87@gmail.com>2012-06-29 00:00:47 -0500
commitd11741d73bbf6940c45ee0f2cadea980e9e40785 (patch)
treef6e51418eccb59fc85bf9e37357f7acc917b4e1d
parent8df96ff5b1d2165b777e98a0f16be7f0499f9565 (diff)
* libremakepkg: don't show nonfree check message if not checking
-rwxr-xr-xlibremakepkg8
1 files changed, 3 insertions, 5 deletions
diff --git a/libremakepkg b/libremakepkg
index f7924f6..873e588 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -23,18 +23,14 @@
# set -x # uncomment for debug
function copy_log { # copy logs if they exist
-
find "${CHROOTDIR}/${CHROOT}/build/" -maxdepth 1 -name "*\.log" -exec cp {} ./ \;
-
}
function trap_exit { # End inmediately but print a useful message
-
copy_log
error "$@"
exit 1
-
}
# Trap signals from makepkg
@@ -95,8 +91,10 @@ if [ ! -e PKGBUILD ]; then # Check if we are actually on a build directory. Do
error "This isn't a build directory"; usage
fi
-msg "Checking PKGBUILD for non-free issues"
if "$CHECKNONFREE"; then
+
+ msg "Checking PKGBUILD for non-free issues"
+
if ! pkgbuild-check-nonfree; then
if [[ $? -eq 15 ]]; then # other errors mean fail, not nonfree