summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-24 14:04:41 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-05-24 14:04:41 -0400
commitd71e71cf7367778df0039d4624b76b2575823a5b (patch)
treee8c9798302349b41811ee0ead89869b478c692b9
parentb8282547fba55b655ad82c34369cf9d0a5c81e3b (diff)
remove stdnull, use plain I/O redirection
-rwxr-xr-xsrc/aur8
-rwxr-xr-xsrc/diff-unfree6
-rwxr-xr-xsrc/libremessages4
3 files changed, 7 insertions, 11 deletions
diff --git a/src/aur b/src/aur
index 12efb81..c9ab267 100755
--- a/src/aur
+++ b/src/aur
@@ -53,7 +53,7 @@ main() {
else
# Store our copy of the PKGBUILD dir
_diff="${PWD}/${_pkg}"
- stdnull "pushd $(mktemp --tmpdir -d ${_pkg}.XXXX)"
+ pushd $(mktemp --tmpdir -d ${_pkg}.XXXX) &>/dev/null
msg2 "Downloading PKGBUILD into ${PWD} for diff"
fi
fi
@@ -67,7 +67,7 @@ main() {
continue
fi
- stdnull "pushd $_pkg"
+ pushd $_pkg &>/dev/null
if [[ ! -z "$_diff" ]]; then
msg2 "Diffing files"
@@ -77,7 +77,7 @@ main() {
done
# Go back to our copy to continue working
- stdnull "pushd ${_diff}"
+ pushd ${_diff} &>/dev/null
fi
. PKGBUILD
@@ -119,7 +119,7 @@ main() {
fi
done
- stdnull popd
+ popd &>/dev/null
done
[[ ${#missing_deps[*]} -gt 0 ]] && {
diff --git a/src/diff-unfree b/src/diff-unfree
index 24ada67..a770214 100755
--- a/src/diff-unfree
+++ b/src/diff-unfree
@@ -63,17 +63,17 @@ main() {
fi
unfree_dir="${tmp_dir}/${svnrepo}/${package}/${trunk}"
- stdnull 'pushd "${tmp_dir}"'
+ pushd "${tmp_dir}" &>/dev/null
msg "Getting diff from $repo/$package..."
- stdnull 'svn checkout --depth=empty svn://svn.archlinux.org/$svnrepo'
+ svn checkout --depth=empty svn://svn.archlinux.org/$svnrepo &>/dev/null
cd ${svnrepo}
svn update ${package}
# Back to start dir
- stdnull popd
+ popd &>/dev/null
msg "Diffing files"
diff --git a/src/libremessages b/src/libremessages
index 4198e4e..8793a80 100755
--- a/src/libremessages
+++ b/src/libremessages
@@ -39,10 +39,6 @@ export TEXTDOMAINDIR='/usr/share/locale'
# Own functions #
################################################################################
-stdnull() {
- eval "$@ &>/dev/null"
-}
-
# Set the terminal title
term_title() {
local fmt=''