summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-01 12:04:19 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:53:57 -0600
commited64cab6615f54f0069a4c48c45d6f1dc85cb9fa (patch)
tree34a3ef64b6949fdc1078a7262b53fa89a50c1ff1
parente1e82671870076a73766e628f8755a1f7e0afe11 (diff)
rm librediff
-rwxr-xr-xsrc/librediff62
-rw-r--r--src/libretools.conf4
2 files changed, 0 insertions, 66 deletions
diff --git a/src/librediff b/src/librediff
deleted file mode 100755
index 3130b86..0000000
--- a/src/librediff
+++ /dev/null
@@ -1,62 +0,0 @@
-#!/bin/bash
-# Generates a patch for a nonfree PKGBUILD
-#
-# Copyright 2010 Nicolás Reynolds
-
-# ---------- GNU General Public License 3 ----------
-
-# This file is part of Parabola.
-
-# Parabola is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-
-# Parabola is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-
-# You should have received a copy of the GNU General Public License
-# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-
-. libremessages
-. $(librelib conf.sh)
-load_files libretools
-check_vars libretools PATCHDIR || exit 1
-
-cmd=${0##*/}
-
-usage() {
- echo "Usage: $cmd <pkgname> [<pkgname2> ...]"
- echo "Requirements:"
- echo " * Have a <pkgname>/ directory with nonfree build scripts inside"
- echo " * Have a <pkgname>-libre/ directory with libre build scripts inside"
-}
-
-main() {
- local packages=("$@")
- if [[ ${packages[#]} = 0 ]]; then
- usage
- exit 1
- fi
-
- for package in "${packages[@]}"; do
- if [[ ! -f ./${package}/PKGBUILD || ! -f ./${package}-libre/PKGBUILD ]]
- then
- error "Build scripts not found for ${package}(-libre)"
- else
- (
- . ./${package}-libre/PKGBUILD
- [[ -z ${pkgbase} ]] && pkgbase=${pkgname}
-
- # Generate a diff file, no -r since we don't want to patch src/ nor pkg/
- diff -auN ${package} ${package}-libre > $PATCHDIR/${pkgbase}-${pkgver}-${pkgrel}.patch
- )
- fi
- done
-
- exit 0
-}
-
-main "$@"
diff --git a/src/libretools.conf b/src/libretools.conf
index 3ca1fda..280bacf 100644
--- a/src/libretools.conf
+++ b/src/libretools.conf
@@ -11,10 +11,6 @@ BLACKLIST=https://repo.parabolagnulinux.org/docs/blacklist.txt
## Used by `aur`, `diff-unfree`
DIFFTOOL=`which vimdiff gvimdiff meld colordiff diff 2>/dev/null|sed 's/\s.*//;1q'`
-## Where to put generated patches
-## Used by `librediff`
-PATCHDIR=/home/$LIBREUSER/packages/patches
-
## The repos you'll be packaging for
## Used by `toru`, `createworkdir`
# Tip: As early repos take precedence on $REPOS loops, you can use this as