summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2014-07-05 02:36:52 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2014-07-05 18:08:47 -0400
commit626705238075a1aceca518e4d464b5df6458750f (patch)
tree74d8d67eea8d4311de5f45f29ff2a26acb6bb3a2
parent739f574f08814694c1b85d72ae8964bc0f0bdf97 (diff)
quote calls to librelib
-rw-r--r--common.mk2
-rwxr-xr-xsrc/abslibre-tools/createworkdir2
-rwxr-xr-xsrc/abslibre-tools/diff-unfree2
-rwxr-xr-xsrc/abslibre-tools/libreaddiff2
-rwxr-xr-xsrc/abslibre-tools/librerelease2
-rwxr-xr-xsrc/abslibre-tools/librestage2
-rwxr-xr-xsrc/aur2
-rw-r--r--src/chroot-tools/arch-nspawn.patch2
-rw-r--r--src/chroot-tools/hooks-distcc.sh2
-rwxr-xr-xsrc/chroot-tools/librechroot8
-rwxr-xr-xsrc/chroot-tools/libremakepkg12
-rw-r--r--src/chroot-tools/mkarchroot.patch2
-rwxr-xr-xsrc/dagpkg2
-rw-r--r--src/devtools/checkpkg.patch2
-rw-r--r--src/devtools/find-libdeps.patch2
-rw-r--r--src/devtools/finddeps.patch2
-rw-r--r--src/devtools/lddd.patch2
-rwxr-xr-xsrc/fullpkg/fullpkg-build2
-rwxr-xr-xsrc/fullpkg/fullpkg-find2
-rw-r--r--src/lib/common.sh.3.ronn2
-rw-r--r--src/lib/conf.sh.3.ronn2
-rwxr-xr-xsrc/lib/libreblacklist4
-rw-r--r--src/lib/libreblacklist.1.ronn2
-rw-r--r--src/lib/librelib.1.ronn14
-rw-r--r--src/lib/librelib.7.ronn4
-rwxr-xr-xsrc/lib/libremessages2
-rw-r--r--src/lib/libremessages.1.ronn2
-rwxr-xr-xsrc/librefetch/librefetch4
-rwxr-xr-xsrc/mips64el-tools/mipsrelease2
-rwxr-xr-xsrc/pkgbuild-check-nonfree6
-rwxr-xr-xsrc/pkgbuild-summarize-nonfree2
-rwxr-xr-xsrc/toru/toru-info2
-rwxr-xr-xsrc/toru/toru-utils2
-rwxr-xr-xsrc/toru/toru-where2
-rwxr-xr-xsrc/treepkg2
-rwxr-xr-xsrc/xbs-abs/helper-abs2
-rwxr-xr-xsrc/xbs/xbs2
37 files changed, 56 insertions, 56 deletions
diff --git a/common.mk b/common.mk
index 30c95e0..7370004 100644
--- a/common.mk
+++ b/common.mk
@@ -9,7 +9,7 @@ pkglibexecdir ?= $(libexecdir)/libretools
# Usage: <INPUT $(edit) >OUTPUT
# Expand m4_include macros to use librelib
# This is used when using sources grabbed from devtools
-edit = sed -e 's|^\#!\s*/bin/bash|\#!/usr/bin/env bash|' -e 's|m4_include(lib/\(.*\))|. $$(librelib \1)|'
+edit = sed -e 's|^\#!\s*/bin/bash|\#!/usr/bin/env bash|' -e 's|m4_include(lib/\(.*\))|. "$$(librelib \1)"|'
# Usage: $(call indent,FILENAME)
# Command to auto-indent a file.
diff --git a/src/abslibre-tools/createworkdir b/src/abslibre-tools/createworkdir
index 8176cce..5599de9 100755
--- a/src/abslibre-tools/createworkdir
+++ b/src/abslibre-tools/createworkdir
@@ -26,7 +26,7 @@
set -euE
. libremessages
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
load_files libretools
check_vars libretools WORKDIR ABSLIBRERECV ABSLIBRESEND # these are asked for by `xbs download`
diff --git a/src/abslibre-tools/diff-unfree b/src/abslibre-tools/diff-unfree
index fc32e77..12c919f 100755
--- a/src/abslibre-tools/diff-unfree
+++ b/src/abslibre-tools/diff-unfree
@@ -23,7 +23,7 @@
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
. libremessages
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
load_files libretools
check_vars libretools DIFFPROG || exit 1
diff --git a/src/abslibre-tools/libreaddiff b/src/abslibre-tools/libreaddiff
index 3f8f8f4..8698920 100755
--- a/src/abslibre-tools/libreaddiff
+++ b/src/abslibre-tools/libreaddiff
@@ -22,7 +22,7 @@
set -e
. libremessages
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
load_files libretools
check_vars libretools WORKDIR
diff --git a/src/abslibre-tools/librerelease b/src/abslibre-tools/librerelease
index 387d411..6b7da5f 100755
--- a/src/abslibre-tools/librerelease
+++ b/src/abslibre-tools/librerelease
@@ -37,7 +37,7 @@
# so we take the '+' to combine it with our GPLv3+.
. libremessages
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
dryrun=""
upload_only=false
diff --git a/src/abslibre-tools/librestage b/src/abslibre-tools/librestage
index 039d9f7..14a040f 100755
--- a/src/abslibre-tools/librestage
+++ b/src/abslibre-tools/librestage
@@ -24,7 +24,7 @@
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
. libremessages
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
usage() {
print "Usage: %s [REPO]" "${0##*/}"
diff --git a/src/aur b/src/aur
index 4057b6e..49c79b9 100755
--- a/src/aur
+++ b/src/aur
@@ -45,7 +45,7 @@ main() {
return 1
fi
- . $(librelib conf.sh)
+ . "$(librelib conf.sh)"
load_files libretools
check_vars libretools DIFFPROG || exit 1
diff --git a/src/chroot-tools/arch-nspawn.patch b/src/chroot-tools/arch-nspawn.patch
index 5e0f10b..792b99f 100644
--- a/src/chroot-tools/arch-nspawn.patch
+++ b/src/chroot-tools/arch-nspawn.patch
@@ -12,7 +12,7 @@
fi
-exec ${CARCH:+setarch "$CARCH"} systemd-nspawn -q \
-+CHROOTARCH="$(. $(librelib conf); get_var chroot CHROOTARCH "$CARCH")"
++CHROOTARCH="$(. "$(librelib conf)"; get_var chroot CHROOTARCH "$CARCH")"
+exec ${CHROOTARCH:+setarch "$CHROOTARCH"} systemd-nspawn -q \
-D "$working_dir" \
--machine "$machine_name" \
diff --git a/src/chroot-tools/hooks-distcc.sh b/src/chroot-tools/hooks-distcc.sh
index 37c82dc..bb234b8 100644
--- a/src/chroot-tools/hooks-distcc.sh
+++ b/src/chroot-tools/hooks-distcc.sh
@@ -62,7 +62,7 @@ distcc_start() {
_distcc_check
- local _distcc_tool=$(librelib chroot/distcc-tool)
+ local _distcc_tool="$(librelib chroot/distcc-tool)"
install -m755 "$_distcc_tool" "$copydir/bin/distcc-tool"
mkdir -p "$home/.ssh"
diff --git a/src/chroot-tools/librechroot b/src/chroot-tools/librechroot
index 4edcb2f..1eba63c 100755
--- a/src/chroot-tools/librechroot
+++ b/src/chroot-tools/librechroot
@@ -30,7 +30,7 @@ set -euE
# - the case statement in main() that checks the number of arguments
# - the case statement in main() that runs them
-. $(librelib conf)
+. "$(librelib conf)"
load_files chroot
. libremessages
@@ -38,9 +38,9 @@ load_files chroot
shopt -s nullglob
umask 0022
-readonly _arch_nspawn=$(librelib chroot/arch-nspawn)
-readonly _mkarchroot=$(librelib chroot/mkarchroot)
-readonly _makechrootpkg=$(librelib chroot/makechrootpkg.sh)
+readonly _arch_nspawn="$(librelib chroot/arch-nspawn)"
+readonly _mkarchroot="$(librelib chroot/mkarchroot)"
+readonly _makechrootpkg="$(librelib chroot/makechrootpkg.sh)"
# Because the makechrootpkg.sh library functions don't work with -euE
_makechrootpkg() (
diff --git a/src/chroot-tools/libremakepkg b/src/chroot-tools/libremakepkg
index aad4217..1512282 100755
--- a/src/chroot-tools/libremakepkg
+++ b/src/chroot-tools/libremakepkg
@@ -24,9 +24,9 @@ set -euE
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-. $(librelib conf)
-. $(librelib messages)
-. $(librelib chroot/makechrootpkg.sh)
+. "$(librelib conf)"
+. "$(librelib messages)"
+. "$(librelib chroot/makechrootpkg.sh)"
set -o pipefail
shopt -s nullglob
@@ -47,9 +47,9 @@ hook_pre_build=(:)
hook_post_build=(:)
hook_check_pkgbuild=(:)
hook_check_pkg=(:)
-. $(librelib chroot/hooks-chcleanup.sh)
-. $(librelib chroot/hooks-check.sh)
-. $(librelib chroot/hooks-distcc.sh)
+. "$(librelib chroot/hooks-chcleanup.sh)"
+. "$(librelib chroot/hooks-check.sh)"
+. "$(librelib chroot/hooks-distcc.sh)"
# Boring/mundane functions #####################################################
diff --git a/src/chroot-tools/mkarchroot.patch b/src/chroot-tools/mkarchroot.patch
index 9366d92..3c8137c 100644
--- a/src/chroot-tools/mkarchroot.patch
+++ b/src/chroot-tools/mkarchroot.patch
@@ -24,7 +24,7 @@
echo "$CHROOT_VERSION" > "$working_dir/.arch-chroot"
-exec arch-nspawn \
-+exec $(librelib chroot/arch-nspawn) \
++exec "$(librelib chroot/arch-nspawn)" \
${pac_conf:+-C "$pac_conf"} \
${makepkg_conf:+-M "$makepkg_conf"} \
${cache_dir:+-c "$cache_dir"} \
diff --git a/src/dagpkg b/src/dagpkg
index 075bbe3..1989b4d 100755
--- a/src/dagpkg
+++ b/src/dagpkg
@@ -23,7 +23,7 @@
set -e
source libremessages
-source $(librelib conf)
+source "$(librelib conf)"
# Source variables from libretools
load_files libretools
diff --git a/src/devtools/checkpkg.patch b/src/devtools/checkpkg.patch
index 2e3bb63..5cfb794 100644
--- a/src/devtools/checkpkg.patch
+++ b/src/devtools/checkpkg.patch
@@ -7,7 +7,7 @@
shopt -s extglob
-m4_include(lib/common.sh)
-+. $(librelib messages)
++. "$(librelib messages)"
+
+usage() {
+ print 'Usage: %s [-h]' "${0##*/}"
diff --git a/src/devtools/find-libdeps.patch b/src/devtools/find-libdeps.patch
index fe8e2fe..1bcffc9 100644
--- a/src/devtools/find-libdeps.patch
+++ b/src/devtools/find-libdeps.patch
@@ -5,7 +5,7 @@
+# License: Unspecified
-m4_include(lib/common.sh)
-+. $(librelib messages)
++. "$(librelib messages)"
set -e
shopt -s extglob
diff --git a/src/devtools/finddeps.patch b/src/devtools/finddeps.patch
index feae920..caf2121 100644
--- a/src/devtools/finddeps.patch
+++ b/src/devtools/finddeps.patch
@@ -7,7 +7,7 @@
+# License: Unspecified
-m4_include(lib/common.sh)
-+. $(librelib messages)
++. "$(librelib messages)"
match=$1
diff --git a/src/devtools/lddd.patch b/src/devtools/lddd.patch
index 415b178..6383aa4 100644
--- a/src/devtools/lddd.patch
+++ b/src/devtools/lddd.patch
@@ -7,7 +7,7 @@
+# License: Unspecified
-m4_include(lib/common.sh)
-+. $(librelib messages)
++. "$(librelib messages)"
+
+usage() {
+ print "Usage: %s [-h]" "${0##*/}"
diff --git a/src/fullpkg/fullpkg-build b/src/fullpkg/fullpkg-build
index a31025e..9a1dcf1 100755
--- a/src/fullpkg/fullpkg-build
+++ b/src/fullpkg/fullpkg-build
@@ -25,7 +25,7 @@
# TODO move __build to chroot
. libremessages
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
load_files makepkg
load_files libretools
check_vars libretools FULLBUILDCMD || exit 1
diff --git a/src/fullpkg/fullpkg-find b/src/fullpkg/fullpkg-find
index af30ed9..ac2099f 100755
--- a/src/fullpkg/fullpkg-find
+++ b/src/fullpkg/fullpkg-find
@@ -157,7 +157,7 @@ find_deps() {
}
. libremessages
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
load_files makepkg
LEVEL=0
diff --git a/src/lib/common.sh.3.ronn b/src/lib/common.sh.3.ronn
index f2bab7a..30003e0 100644
--- a/src/lib/common.sh.3.ronn
+++ b/src/lib/common.sh.3.ronn
@@ -3,7 +3,7 @@ common.sh -- common Bash routines from devtools
## SYNOPSIS
-`. $(librelib common)`
+`. "$(librelib common)"`
## DESCRIPTION
diff --git a/src/lib/conf.sh.3.ronn b/src/lib/conf.sh.3.ronn
index 7a4b413..bad271d 100644
--- a/src/lib/conf.sh.3.ronn
+++ b/src/lib/conf.sh.3.ronn
@@ -3,7 +3,7 @@ conf.sh(3) -- easy loading of configuration files
## SYNOPSIS
-`. $(librelib conf)`
+`. "$(librelib conf)"`
## DESCRIPTION
diff --git a/src/lib/libreblacklist b/src/lib/libreblacklist
index eeb6b7f..484c536 100755
--- a/src/lib/libreblacklist
+++ b/src/lib/libreblacklist
@@ -20,7 +20,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
# make sure XDG_CACHE_HOME is set
-. $(librelib conf)
+. "$(librelib conf)"
# Usage: blacklist-normalize <$file
# Normalizes the syntax of the blacklist on stdin.
@@ -113,7 +113,7 @@ if [[ "${0##*/}" == libreblacklist ]]; then
usage() {
export TEXTDOMAIN='librelib'
export TEXTDOMAINDIR='/usr/share/locale'
- . $(librelib messages)
+ . "$(librelib messages)"
if [[ $# -eq 0 ]]; then
print "Usage: %s [-h] COMMAND [ARGUMENTS]" "${0##*/}"
print "Tool for working with the nonfree software blacklist"
diff --git a/src/lib/libreblacklist.1.ronn b/src/lib/libreblacklist.1.ronn
index 550ace8..bef9d67 100644
--- a/src/lib/libreblacklist.1.ronn
+++ b/src/lib/libreblacklist.1.ronn
@@ -3,7 +3,7 @@ libreblacklist(1) -- Tools for working with the your-freedom blacklist
## SYNOPSIS
-`. $(librelib blacklist)`<br>
+`. "$(librelib blacklist)"`<br>
`. libreblacklist`<br>
`libremessages` [-h] <COMMAND> [<ARGS>...]
diff --git a/src/lib/librelib.1.ronn b/src/lib/librelib.1.ronn
index b3fc35e..fe64e92 100644
--- a/src/lib/librelib.1.ronn
+++ b/src/lib/librelib.1.ronn
@@ -3,7 +3,7 @@ librelib(1) -- finds a Bash library file
## SYNOPSIS
-`. $(librelib LIBRARY)`<br>
+`. "$(librelib LIBRARY)"`<br>
`librelib -h`
## DESCRIPTION
@@ -32,10 +32,10 @@ When searching for a library, `librelib` first strips `libre` from the
beginning of the name, and `.sh` from the end. This means that all of
the following are equivalent:
- . $(librelib messages)
- . $(librelib messages.sh)
- . $(librelib libremessages)
- . $(librelib libremessages.sh)
+ . "$(librelib messages)"
+ . "$(librelib messages.sh)"
+ . "$(librelib libremessages)"
+ . "$(librelib libremessages.sh)"
Once it has the 'base' name of the library it is looking for, it looks
for a file with that 'base' name (allowing for, but not requiring
@@ -47,8 +47,8 @@ message to standard error, and exit with a code of 1.
## Examples
- . $(librelib messages)
- . $(librelib conf)
+ . "$(librelib messages)"
+ . "$(librelib conf)"
## SEE ALSO
diff --git a/src/lib/librelib.7.ronn b/src/lib/librelib.7.ronn
index 3116462..31fb65f 100644
--- a/src/lib/librelib.7.ronn
+++ b/src/lib/librelib.7.ronn
@@ -27,14 +27,14 @@ if they are invoked directly, the first argument is the library
routine to be executed. For example, the `messages` library may be
included, or executed:
- . $(librelib messages)
+ . "$(librelib messages)"
msg2 "Foo was found: %s" "$foo"
# or
libremessages msg2 "Foo was found: %s" "$foo"
The `blacklist` library is similar:
- . $(librelib blacklist)
+ . "$(librelib blacklist)"
blacklist-update
# or
libreblacklist update
diff --git a/src/lib/libremessages b/src/lib/libremessages
index aadd91e..429a997 100755
--- a/src/lib/libremessages
+++ b/src/lib/libremessages
@@ -34,7 +34,7 @@
# Inherit most functions from devtools #
################################################################################
-. $(librelib common.sh)
+. "$(librelib common.sh)"
################################################################################
# Own functions #
diff --git a/src/lib/libremessages.1.ronn b/src/lib/libremessages.1.ronn
index b3cf13d..5d58fb5 100644
--- a/src/lib/libremessages.1.ronn
+++ b/src/lib/libremessages.1.ronn
@@ -3,7 +3,7 @@ libremessages(1) -- common Bash routines
## SYNOPSIS
-`. $(librelib messages)`<br>
+`. "$(librelib messages)"`<br>
`. libremessages`<br>
`libremessages` <COMMAND>
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 1c793aa..c3e1700 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -20,8 +20,8 @@
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-. $(librelib conf)
-. $(librelib messages)
+. "$(librelib conf)"
+. "$(librelib messages)"
setup_traps
declare -r tempdir="$(mktemp -d --tmpdir ${0##*/}.XXXXXXXXXXX)"
diff --git a/src/mips64el-tools/mipsrelease b/src/mips64el-tools/mipsrelease
index fec2a1b..a91934a 100755
--- a/src/mips64el-tools/mipsrelease
+++ b/src/mips64el-tools/mipsrelease
@@ -25,7 +25,7 @@
# $2+ packages
. libremessages
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
load_files makepkg
check_vars makepkg CARCH PKGDEST PKGEXT || exit 1
load_files libretools
diff --git a/src/pkgbuild-check-nonfree b/src/pkgbuild-check-nonfree
index 11eaf42..67f07bc 100755
--- a/src/pkgbuild-check-nonfree
+++ b/src/pkgbuild-check-nonfree
@@ -27,9 +27,9 @@
# I appologize that this program got *huge*.
# It's not complicated, just long.
-. $(librelib messages)
-. $(librelib conf)
-. $(librelib blacklist)
+. "$(librelib messages)"
+. "$(librelib conf)"
+. "$(librelib blacklist)"
usage() {
print "Usage: %s [OPTIONS] [PKGBUILD1 PKGBUILD2 ...]" "${0##*/}"
diff --git a/src/pkgbuild-summarize-nonfree b/src/pkgbuild-summarize-nonfree
index 9b3d8e6..1e39e87 100755
--- a/src/pkgbuild-summarize-nonfree
+++ b/src/pkgbuild-summarize-nonfree
@@ -18,7 +18,7 @@
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-. $(librelib messages)
+. "$(librelib messages)"
# Make sure these match pkgbuild-check-nonfree
declare -ri _E_OK=0
diff --git a/src/toru/toru-info b/src/toru/toru-info
index a427050..f76fc07 100755
--- a/src/toru/toru-info
+++ b/src/toru/toru-info
@@ -19,7 +19,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
. libremessages
-. $(librelib conf)
+. "$(librelib conf)"
for _pkg in $@; do
_pkgbuild="$(toru-where $_pkg)"
diff --git a/src/toru/toru-utils b/src/toru/toru-utils
index 164f418..6ba02be 100755
--- a/src/toru/toru-utils
+++ b/src/toru/toru-utils
@@ -19,7 +19,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
. libremessages
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
load_files libretools
check_vars libretools TORUPATH || exit 1
diff --git a/src/toru/toru-where b/src/toru/toru-where
index e70d135..e042146 100755
--- a/src/toru/toru-where
+++ b/src/toru/toru-where
@@ -18,7 +18,7 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-. $(librelib conf.sh)
+. "$(librelib conf.sh)"
load_files libretools
check_vars libretools TORUPATH || exit 1
diff --git a/src/treepkg b/src/treepkg
index f417010..9b6d34f 100755
--- a/src/treepkg
+++ b/src/treepkg
@@ -19,7 +19,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
source libremessages
-source $(librelib conf.sh)
+source "$(librelib conf.sh)"
load_files libretools
check_vars libretools FULLBUILDCMD || exit 1
diff --git a/src/xbs-abs/helper-abs b/src/xbs-abs/helper-abs
index 6c57803..5e207eb 100755
--- a/src/xbs-abs/helper-abs
+++ b/src/xbs-abs/helper-abs
@@ -32,7 +32,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
load_config() {
- . $(librelib conf.sh)
+ . "$(librelib conf.sh)"
load_files xbs-abs
# SVNUSER is optional
check_vars SVNDIR SVNREPOS ARCHES || exit 1
diff --git a/src/xbs/xbs b/src/xbs/xbs
index a81d37c..1c00d60 100755
--- a/src/xbs/xbs
+++ b/src/xbs/xbs
@@ -20,7 +20,7 @@
default_libdir=/usr/lib/xbs
. libremessages
-. $(librelib conf)
+. "$(librelib conf)"
errusage() {
if [[ $# -gt 0 ]]; then