summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-06-20 09:45:54 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-06-20 09:45:54 -0400
commit338f268cfd32560edb2a0dc82085e833c5b4b548 (patch)
treef800575fee7b4800df8cecb93c108f47976ed759
parent36582d9a7c2cf8189f95c41a139605063e441707 (diff)
Fix some hard-coded shebangs
-rw-r--r--common.mk2
-rwxr-xr-xsrc/pkgbuild-summarize-nonfree2
2 files changed, 2 insertions, 2 deletions
diff --git a/common.mk b/common.mk
index 58366d7..f8421d4 100644
--- a/common.mk
+++ b/common.mk
@@ -8,7 +8,7 @@ pkglibexecdir ?= $(libexecdir)/libretools
# Usage: <INPUT $(edit) >OUTPUT
# Expand m4_include macros to use librelib
# This is used when using sources grabbed from devtools
-edit = sed -e 's|m4_include(lib/\(.*\))|. $$(librelib \1)|'
+edit = sed -e 's|^\#!\s*/bin/bash|\#!/usr/bin/env bash|' -e 's|m4_include(lib/\(.*\))|. $$(librelib \1)|'
# Usage: $(call indent,FILENAME)
# Command to auto-indent a file.
diff --git a/src/pkgbuild-summarize-nonfree b/src/pkgbuild-summarize-nonfree
index cf3be28..9b3d8e6 100755
--- a/src/pkgbuild-summarize-nonfree
+++ b/src/pkgbuild-summarize-nonfree
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
# Copyright (C) 2013 Luke Shumaker <lukeshu@sbcglobal.net>
#
# License: GNU GPLv3+