summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@endefensadelsl.org>2013-06-20 18:21:41 -0300
committerNicolás Reynolds <fauno@endefensadelsl.org>2013-06-20 18:21:41 -0300
commit6d6b719221d3b4190325b43a3fbfd14405765420 (patch)
tree4fb4bfa0c0447d7304a069a38ac26d7f1fb4bdc8
parent513c5bd2a6c5569daae8c9b84413f3b85b05cae1 (diff)
Search shell in path
-rwxr-xr-xabslibre-commit2
-rwxr-xr-xadd-mips64el2
-rwxr-xr-xaur2
-rwxr-xr-xbuildenv2
-rwxr-xr-xchcleanup2
-rwxr-xr-xcreateworkdir2
-rwxr-xr-xdiff-unfree2
-rwxr-xr-xis_built2
-rwxr-xr-xtoru-where2
9 files changed, 9 insertions, 9 deletions
diff --git a/abslibre-commit b/abslibre-commit
index e906fbd..bca64c0 100755
--- a/abslibre-commit
+++ b/abslibre-commit
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
# ABSLibreCommit
# Commits a PKGBUILD to ABSLibre.git
diff --git a/add-mips64el b/add-mips64el
index e06d857..17b167b 100755
--- a/add-mips64el
+++ b/add-mips64el
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
# Change all arch array that aren't any or mips64el already
find -name 'PKGBUILD' -exec sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" '{}' \;
diff --git a/aur b/aur
index 24d4317..c6bd6b0 100755
--- a/aur
+++ b/aur
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
# Copyright 2010 Nicolás Reynolds, Joshua Ismael
# ---------- GNU General Public License 3 ----------
diff --git a/buildenv b/buildenv
index 84a1fc2..5caea0c 100755
--- a/buildenv
+++ b/buildenv
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
trap "umount_all" 0 ERR TERM KILL
diff --git a/chcleanup b/chcleanup
index 17c1f02..b1a02db 100755
--- a/chcleanup
+++ b/chcleanup
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
# (c) Nicolás Reynolds <fauno@parabola.nu>
# Released under GPLv3
#
diff --git a/createworkdir b/createworkdir
index b443c08..6a4de10 100755
--- a/createworkdir
+++ b/createworkdir
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
# CreateWorkDir
# Creates a dir structure for working with Parabola packages
diff --git a/diff-unfree b/diff-unfree
index a0a8d63..7d75375 100755
--- a/diff-unfree
+++ b/diff-unfree
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
# This script will help you diff a *-libre PKGBUILD against the unfree one
# to check for updates.
# Copyright 2010 Nicolás Reynolds
diff --git a/is_built b/is_built
index 1fa79d2..d6aafd9 100755
--- a/is_built
+++ b/is_built
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
usage() {
echo "$0 "
echo
diff --git a/toru-where b/toru-where
index e9ab29d..0cbba6f 100755
--- a/toru-where
+++ b/toru-where
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
# Locates a PKGBUILD dir on toru's path cache
source /etc/libretools.conf