summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-01-01 20:57:13 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-01-01 20:57:13 -0500
commit503517c61c64bb18dc64574b5b02fb973a110891 (patch)
tree1b048174d1bd580a907e97f59ee77294c24ccaa5
parent2c981bb6e7f5ddb1b71a2a4e314ba7cd523d857c (diff)
makepkg no longer supports split packages with different pkgver
-rw-r--r--test/librestage-test.sh14
-rw-r--r--test/librestage.d/PKGBUILD-split42
2 files changed, 0 insertions, 56 deletions
diff --git a/test/librestage-test.sh b/test/librestage-test.sh
index edcfc36..affad6a 100644
--- a/test/librestage-test.sh
+++ b/test/librestage-test.sh
@@ -48,20 +48,6 @@ it_fails_with_invalid_args() {
not empty "$tmpdir/stderr"
}
-# This was an actual bug I hit with md/emacs-mdmua a long time ago; solution was
-# to use $(get_full_version)
-it_stages_split_packages_with_different_versions() {
- cp librestage.d/PKGBUILD-split "$tmpdir/PKGBUILD"
- cd "$tmpdir"
-
- makepkg
- librestage '~lukeshu'
-
- # peak at the PKGBUILD to get this info
- [[ -f $tmpdir/workdir/staging/~lukeshu/md-0.81-4-any.pkg.tar.gz ]]
- [[ -f $tmpdir/workdir/staging/~lukeshu/emacs-mdmua-0.72-4-any.pkg.tar.gz ]]
-}
-
it_guesses_the_repo() {
mkdir -p -- "$tmpdir/reponame/libretools-hello"
cp librestage.d/PKGBUILD-hello "$tmpdir/reponame/libretools-hello/PKGBUILD"
diff --git a/test/librestage.d/PKGBUILD-split b/test/librestage.d/PKGBUILD-split
deleted file mode 100644
index a8ec1ef..0000000
--- a/test/librestage.d/PKGBUILD-split
+++ /dev/null
@@ -1,42 +0,0 @@
-# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
-
-pkgname=("md" "emacs-mdmua")
-pkgver=0.81
-pkgrel=4
-arch=('any')
-url="https://github.com/nicferrier/$_pkgname"
-license=('GPL3')
-
-#makedepends=(python-distribute)
-
-#__gitbranch=1d69744 # This is the commit that is 0.81
-__gitbranch=455b6b4 # this is currently HEAD (has bugfixes)
-#source=("nicferrier-md-${__gitbranch}.tar.gz::https://github.com/nicferrier/$pkgname/tarball/${__gitbranch}")
-
-#build() {
-# cd "${srcdir}/nicferrier-md-${__gitbranch}"
-#
-# # fix typo
-# sed -i 's/pyprofyfs/pyproxyfs/' setup.py
-#}
-
-package_md() {
- pkgdesc="A maildir client and library."
- depends=('python' 'python-pyproxyfs')
-
-# cd "${srcdir}/nicferrier-md-${__gitbranch}"
-# python setup.py install --root="$pkgdir/" --optimize=1
-}
-
-package_emacs-mdmua() {
- pkgdesc="An Emacs mail user agent (MUA) build around md."
- pkgver='0.72'
- depends=("md=0.81" 'emacs>=24')
-
-# cd "${srcdir}/nicferrier-md-${__gitbranch}"
-# cd useragents/emacs
-# install -d ${pkgdir}/usr/share/emacs/site-lisp
-# install -m 644 *.el ${pkgdir}/usr/share/emacs/site-lisp
-}
-
-#md5sums=('452727348df2f51d7eddade709aceb1c')