summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-06-06 18:04:15 -0600
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-06-06 18:04:15 -0600
commitba2e25c29ce92e694a4cc431419ce21e241bb50d (patch)
tree8553c1c4d9329145fb2bb850e6e2231dc87e5b50
parent5161c0f6bd379b8ae74c59874eb71d6782972d61 (diff)
remove mips64el-tools: We don't support MIPS anymore
-rw-r--r--Makefile3
-rw-r--r--src/libretools.conf3
-rw-r--r--src/mips64el-tools/Makefile1
-rwxr-xr-xsrc/mips64el-tools/add-mips64el23
-rwxr-xr-xsrc/mips64el-tools/librebasebuilder87
-rwxr-xr-xsrc/mips64el-tools/mips-add25
-rwxr-xr-xsrc/mips64el-tools/mipsrelease78
7 files changed, 2 insertions, 218 deletions
diff --git a/Makefile b/Makefile
index cd12f75..e9c01ce 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@ include config.mk
################################################################################
# these are the resulting packages
-packages=doc libretools libretools-mips64el librelib gitget xbs
+packages=doc libretools librelib gitget xbs
# and which directories they contain
doc=doc
libretools=\
@@ -14,7 +14,6 @@ libretools=\
src/devtools \
src/librefetch \
src/toru
-libretools-mips64el=src/mips64el-tools
librelib=src/lib
gitget=src/gitget
xbs=\
diff --git a/src/libretools.conf b/src/libretools.conf
index e2a661d..cde9939 100644
--- a/src/libretools.conf
+++ b/src/libretools.conf
@@ -16,7 +16,7 @@ DIFFPROG=$(which $([ -z "${DISPLAY:-}" ]||echo kdiff3 meld gvimdiff) vimdiff col
## The architectures you'll be packaging for
## Used by `librestage`, `xbs-abslibre`
-ARCHES=('x86_64' 'i686' 'mips64el')
+ARCHES=('x86_64' 'i686')
## ABSLibre
# Used by xbs-abslibre
@@ -56,7 +56,6 @@ FULLBUILDCMD="sudo libremakepkg"
# Locally release the package or any other action after running FULLBUILDCMD
# successfully. When run, it is given a repository name as a single argument.
HOOKLOCALRELEASE="librestage"
-#HOOKLOCALRELEASE="mipsrelease"
################################################################################
# toru #
diff --git a/src/mips64el-tools/Makefile b/src/mips64el-tools/Makefile
deleted file mode 100644
index 2c76089..0000000
--- a/src/mips64el-tools/Makefile
+++ /dev/null
@@ -1 +0,0 @@
-include ../../common.mk
diff --git a/src/mips64el-tools/add-mips64el b/src/mips64el-tools/add-mips64el
deleted file mode 100755
index bb1bb69..0000000
--- a/src/mips64el-tools/add-mips64el
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/usr/bin/env bash
-# Change all arch array that aren't any or mips64el already
-
-# Copyright (C) 2011 Nicolás Reynolds <fauno@parabola.nu>
-#
-# License: GNU GPLv3+
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-find -name 'PKGBUILD' -exec sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" '{}' \;
-
-exit $?
diff --git a/src/mips64el-tools/librebasebuilder b/src/mips64el-tools/librebasebuilder
deleted file mode 100755
index 61f638d..0000000
--- a/src/mips64el-tools/librebasebuilder
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/usr/bin/env bash
-# -*- coding: utf-8 -*-
-
-# Copyright (C) 2012 Michał Masłowski <mtjm@mtjm.eu>
-#
-# License: GNU GPLv3+
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-
-set -e
-
-# TODO:
-
-# - make it more configurable
-
-# - compare the result with previous base images
-
-for arg in "$@" ; do
- case "$arg" in
- -h|--h|--he|--hel|--help|-\?)
- echo 'Usage: librebasebuilder
-
-Make a base tarball named parabola-mips64el-DATE.tar.bz2.
-
-This script must be run as root.' >&2
- exit 0
- ;;
- esac
-done
-
-[[ "$UID" != "0" ]] && {
- echo "This script must be run as root." >&2
- exit 1
-}
-
-tempdir=/home/chroot/base
-outdir=$(pwd)
-
-archroot -n $tempdir mkinitcpio base sudo parted nano zile vi ed openssh
-
-cd $tempdir
-
-# Don't list mtjm's DNS servers.
-cat > etc/resolv.conf <<EOF
-#
-# /etc/resolv.conf
-#
-
-#search <yourdomain.tld>
-#nameserver <ip>
-
-# End of file
-EOF
-
-# From pacman-mirrorlist-libre-20120307-1. Remember to escape dollars.
-cat > etc/pacman.d/mirrorlist <<EOF
-# Parabola GNU/Linux - Last Updated: Wed Mar 7 17:33:36 GMT 2012
-
-# Atlanta, GA, USA
-# Responsible: belos
-Server = http://parabola.techno-geeks.org/\$repo/os/\$arch
-
-# Nuremberg, Germany
-# Responsible: johkra
-Server = http://parabolaweb.eu/\$repo/os/\$arch
-
-# UK
-# Responsible: Parabola Project
-Server = http://repo.parabola.nu/\$repo/os/\$arch
-
-EOF
-
-rm .arch-chroot
-
-tar cjf $outdir/parabola-mips64el-$(LC_ALL=C date -u +%Y%m%d).tar.bz2 .
diff --git a/src/mips64el-tools/mips-add b/src/mips64el-tools/mips-add
deleted file mode 100755
index ef708ec..0000000
--- a/src/mips64el-tools/mips-add
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/usr/bin/env bash
-# Copyright (C) 2011 Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
-#
-# License: GNU GPLv3+
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-. libremessages
-if ! grep mips64el PKGBUILD >/dev/null; then # Add mips64el in ${arch} array if it isn't 'any'
- warning "Adding mips64el arch"
- sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" "PKGBUILD"
- git add PKGBUILD
- git commit
-fi
diff --git a/src/mips64el-tools/mipsrelease b/src/mips64el-tools/mipsrelease
deleted file mode 100755
index a91934a..0000000
--- a/src/mips64el-tools/mipsrelease
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/usr/bin/env bash
-# Local release of mips64el packages + clean ABS sync
-# Called by HOOKLOCALRELEASE
-
-# Copyright (C) 2011 Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
-# Copyright (C) 2011-2012 Nicolás Reynolds <fauno@parabola.nu>
-# Copyright (C) 2013 Luke Shumaker <lukeshu@sbcglobal.net>
-#
-# License: GNU GPLv3+
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-# $1 repo
-# $2+ packages
-
-. libremessages
-. "$(librelib conf.sh)"
-load_files makepkg
-check_vars makepkg CARCH PKGDEST PKGEXT || exit 1
-load_files libretools
-check_vars libretools WORKDIR || exit 1
-
-usage() {
- echo "$0 repo"
- echo
- echo " release packages locally on \${PKGDEST}/stage3."
- echo " and make a clean ABS sync "
-}
-
-main() {
- if [[ $# != 1 ]]; then
- usage
- exit 1
- fi
-
- repo=$1
-
- if [ -z "${repo}" ]; then
- error "Empty repo"
- exit 1
- fi
-
- # Get all needed sources
- load_PKGBUILD
- pkgs=()
- makepkg --source -f --skippgpcheck -c
-
- msg "Adding packages to [stage3]..."
- for name in "${pkgname[@]}"; do
- msg2 "${name} $(get_full_version $name)"
- pkgs+=(${PKGDEST}/${name}-$(get_full_version $name)-*.pkg.tar.*)
- done
-
- repo-add ${PKGDEST}/stage3.db.tar.gz "${pkgs[@]}"
-
- librestage ${repo}
-
- mkdir -p ${WORKDIR}/abs/${CARCH}/${repo} >/dev/null
-
- pushd ${WORKDIR}/abs/${CARCH}/${repo} >/dev/null
- tar xvf $SRCPKGDEST/${pkgbase:-${pkgname[0]}}-$(get_full_version)${SRCEXT}
- popd >/dev/null
-
- exit $?
-}
-
-main "$@"