summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-03-03 19:14:44 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-03-03 19:14:44 -0500
commit225ca4b3f8efb7c95cf204bef3ddae3d432b3ec6 (patch)
tree26772f92b5778fb3fe02d36def03df6c25e7364f
parent39da5faef0376f5fd0472aa013c6e5f81474c2d2 (diff)
Add a check so that it errors sensibly if devtoolsdir is set incorrectly.
-rw-r--r--common.once.head.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/common.once.head.mk b/common.once.head.mk
index d7faab8..45d51b4 100644
--- a/common.once.head.mk
+++ b/common.once.head.mk
@@ -20,6 +20,10 @@ MAKEFLAGS += --no-builtin-rules --no-builtin-variables
.PHONY: FORCE
+ifeq ($(wildcard $(devtoolsdir)/),)
+$(error config.mk:devtoolsdir points to a non-existant directory: $(devtoolsdir))
+endif
+
write-ifchanged = $(topsrcdir)/write-ifchanged
# Magic for tracking variables that affect files. If a file changes