summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-09-16 21:05:36 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-09-16 21:05:36 -0400
commit11a5c34a9d9edc353e7c6da763186c59339ae229 (patch)
tree15ad81ae56197e6ee56ca8f5569045056b73c67d
parentd9a42e4a98877512a8f1419270fddf156a1b2038 (diff)
common.mk: begone with $(rootdir), use the more reliable -r flag
-rw-r--r--common.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/common.mk b/common.mk
index 69bcc06..66d6c24 100644
--- a/common.mk
+++ b/common.mk
@@ -28,11 +28,6 @@ indent = emacs --batch $1 \
# Normalize a .po(t) file
pofmt = msguniq -Fi --to-code=UTF-8
-# Usage: as a variable
-# relative path to `/` from $(bindir)
-# used for symlinking libexec files
-rootdir = $(shell sed -r 's|^/||;s|[^/]+|..|g'<<<$(bindir))
-
# Detect things about the director we're in ####################################
progs += $(filter-out $(no-progs),$(shell find . -maxdepth 1 -type f -executable -printf '%f\n'))
@@ -125,7 +120,7 @@ $(sort $(addprefix $(DESTDIR)$(bindir)/,$(filter-out $(libexecs),$(progs)))): $(
install -Dm755 '$<' '$@'
$(sort $(addprefix $(DESTDIR)$(bindir)/,$(libexecs))): $(DESTDIR)$(bindir)/%: %
install -d '$(@D)'
- ln -sf '$(rootdir)$(pkglibexecdir)/$(@F)' "$@"
+ ln -srf '$(pkglibexecdir)/$(@F)' '$@'
# pkglibexecdir: $(libexecs) vs $(libs)
$(sort $(addprefix $(DESTDIR)$(pkglibexecdir)/,$(libexecs))): $(DESTDIR)$(pkglibexecdir)/%: %
install -Dm755 '$<' '$@'