summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-05-05 13:17:05 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-05-05 17:38:39 -0400
commit59b3b8500c6bf484b9b1ccfc2b88d47a9592e0f4 (patch)
treeca641fe4d07c3d5cb8368d7459b1770708770c2b
parentdbcc8a0dc40ce467f3b11b0bb8029b96a72dc3cf (diff)
librestage: ditch xbs in favor of uploading sourceballs
-rwxr-xr-xsrc/abslibre-tools/librestage24
1 files changed, 15 insertions, 9 deletions
diff --git a/src/abslibre-tools/librestage b/src/abslibre-tools/librestage
index b8278d2..beeb240 100755
--- a/src/abslibre-tools/librestage
+++ b/src/abslibre-tools/librestage
@@ -59,17 +59,12 @@ main() {
return 1
fi
- if ! xbs -b abslibre status; then
- error "There are uncommitted changes in the current directory"
- return 1
- fi
-
# Load configuration
load_files libretools
- # ABSLIBREDEST is used by xbs release-client
- check_vars libretools WORKDIR ARCHES ABSLIBREDEST || return 1
- load_files makepkg # for PKGDEST and SRCDEST, which are optional
+ check_vars libretools WORKDIR ARCHES || return 1
+ load_files makepkg # for PKGDEST, SRCDEST, and SRCPKGDEST, which are optional
load_files librefetch # for MIRRORS, which is optional
+ SRCPKGPOOL="$WORKDIR/staging/sources/parabola"
# Load the PKGBUILD
load_PKGBUILD
@@ -94,7 +89,6 @@ main() {
die "PACKAGER wes not set when building package"
fi
- xbs -b abslibre release-client "$repo" "$CARCH"
mkdir -p "${WORKDIR}/staging/${repo}"
if cp "$pkgfile" "${WORKDIR}/staging/${repo}/${pkgfile##*/}"; then
msg2 "%s staged on [%s]" "$_pkgname" "$repo"
@@ -104,6 +98,18 @@ main() {
return 1
fi
done
+ if pkgfile=$(find_cached_srcpackage "$pkgbase" "$(get_full_version)" "$CARCH"); then
+ msg 'Found source package: %s' "${pkgfile##*/}"
+
+ mkdir -p "$SRCPKGPOOL"
+ if cp "$pkgfile" "$SRCPKGPOOL/${pkgfile##*/}"; then
+ msg2 "%s staged on [%s]" "$pkgbase" sources
+ staged=true
+ else
+ error "Can't put %s on [%s]" "$pkgbase" sources
+ return 1
+ fi
+ fi
done
# Look for librefetch output