summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 20:22:29 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 20:22:29 -0400
commit6c17560b9177c3354751bb4716ee1b17ddb3f172 (patch)
treeec2ce868f706fc54705a1c36fce0f76d28c43422
parente3d7fbca888e07f02c5867dd1e50393247a066b7 (diff)
po: do checks on localizations before compiling them
-rw-r--r--po/subdir.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/po/subdir.mk b/po/subdir.mk
index 3cddb5d..b9a2575 100644
--- a/po/subdir.mk
+++ b/po/subdir.mk
@@ -5,7 +5,8 @@ locale = $(notdir $(srcdir))
domains = $(patsubst %.po,%,$(filter %.po,$(files.src.src)))
$(outdir)/%.mo: $(srcdir)/%.po $(call at.path,$(srcdir)/../%.pot)
- msgfmt -o $@ $<
+ msgcmp --use-untranslated $< $(word 2,$^)
+ msgfmt -c -o $@ $<
$(DESTDIR)$(localedir)/$(locale)/LC_MESSAGES/%.mo: $(outdir)/%.mo
install -T -Dm644 '$<' '$@'