summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-07-08 21:31:13 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-07-08 21:31:13 -0400
commitaa4a03eae20d3de63c6e2659ebdfe1be5db434ee (patch)
tree239cdb790fc7f06a2688acd76ddea160c088b460
parentb3e5bf9dec22dd447ddb7d466f3e73b6f0f5b533 (diff)
Makefile: have docdir behave the way the GNU standards say.
I had docdir = $(datarootdir)/doc pkgdocdir = $(docdir)/libretools # install docs to $(pkgdocdir) but the GNU Coding Standards (July 25, 2016 revision), say I should be doing docdir = $(datarootdir)/doc/libretools # install docs to $(docdir) As the config.mk states, we aren't a GNU package. But let's still follow their standards here, to follow the principle of least surprise.
-rw-r--r--build-aux/Makefile.each.head/20-libretools.mk1
-rw-r--r--build-aux/Makefile.each.tail/20-libretools.mk4
-rw-r--r--build-aux/Makefile.once.head/00-libretools.mk1
-rw-r--r--config.mk1
4 files changed, 2 insertions, 5 deletions
diff --git a/build-aux/Makefile.each.head/20-libretools.mk b/build-aux/Makefile.each.head/20-libretools.mk
index 20abd8b..be4b8aa 100644
--- a/build-aux/Makefile.each.head/20-libretools.mk
+++ b/build-aux/Makefile.each.head/20-libretools.mk
@@ -14,7 +14,6 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
pkgconfdir = $(sysconfdir)/libretools.d
-pkgdocdir = $(docdir)/libretools
pkglibexecdir = $(libexecdir)/libretools
# Auto-detect ########################################################
diff --git a/build-aux/Makefile.each.tail/20-libretools.mk b/build-aux/Makefile.each.tail/20-libretools.mk
index 49e8fb8..4398e2c 100644
--- a/build-aux/Makefile.each.tail/20-libretools.mk
+++ b/build-aux/Makefile.each.tail/20-libretools.mk
@@ -26,7 +26,7 @@ files.out.all += $(filter-out $(files.src),$(libretools.out)) \
files.sys.all += $(addprefix $(bindir)/,$(libretools.out.bins)) \
$(addprefix $(pkgconfdir)/,$(libretools.out.confs)) \
$(addprefix $(pkglibexecdir)/,$(libretools.out.libexecs) $(libretools.out.libs)) \
- $(addprefix $(pkgdocdir)/,$(libretools.out.docs)) \
+ $(addprefix $(docdir)/,$(libretools.out.docs)) \
$(addprefix $(mandir)/man1/,$(filter %.1,$(libretools.out.mans))) \
$(addprefix $(mandir)/man2/,$(filter %.2,$(libretools.out.mans))) \
$(addprefix $(mandir)/man3/,$(filter %.3,$(libretools.out.mans))) \
@@ -61,7 +61,7 @@ $(outdir)/everything.pot: $(addprefix $(outdir)/,$(addsuffix .pot,$(libretools.p
# Install rules ######################################################
$(DESTDIR)$(pkgconfdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'
-$(DESTDIR)$(pkgdocdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(docdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'
$(DESTDIR)$(mandir)/man1/%.1: $(outdir)/%.1; install -T -Dm644 '$<' '$@'
$(DESTDIR)$(mandir)/man2/%.2: $(outdir)/%.2; install -T -Dm644 '$<' '$@'
$(DESTDIR)$(mandir)/man3/%.3: $(outdir)/%.3; install -T -Dm644 '$<' '$@'
diff --git a/build-aux/Makefile.once.head/00-libretools.mk b/build-aux/Makefile.once.head/00-libretools.mk
index 1f2957d..7c1ffef 100644
--- a/build-aux/Makefile.once.head/00-libretools.mk
+++ b/build-aux/Makefile.once.head/00-libretools.mk
@@ -18,7 +18,6 @@ define mod.libretools.doc
# Inputs:
# - Install paths (Directory variables):
# - `pkgconfdir = $(sysconfdir)/libretools.d`
-# - `pkgdocdir = $(docdir)/libretools`
# - `pkglibexecdir = $(libexecdir)/libretools`
# - Outputs (Directory variables):
# - `libretools.out.mans`
diff --git a/config.mk b/config.mk
index 0d564e0..882e2e9 100644
--- a/config.mk
+++ b/config.mk
@@ -26,7 +26,6 @@ datadir = $(datarootdir)
#sysconfdir = $(prefix)/etc
sysconfdir = /etc
-docdir = $(datarootdir)/doc
mandir = $(datarootdir)/man
devtoolsdir = $(call abspath,$(topsrcdir)/../devtools-par)