summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-07-08 21:32:08 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-07-08 21:32:08 -0400
commitafc6093ea5b87d2d4c870cef7ef66548d3d576ba (patch)
tree14430690d1e0fe5ab3f08a9444621066efa25162
parentaa4a03eae20d3de63c6e2659ebdfe1be5db434ee (diff)
Makefile: rename $(outdir)/everything.pot to $(srcdir)/dir.pot
-rw-r--r--Makefile2
-rw-r--r--build-aux/Makefile.each.tail/20-libretools.mk8
-rw-r--r--build-aux/Makefile.once.head/00-libretools.mk2
3 files changed, 5 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index e7b35e4..444a669 100644
--- a/Makefile
+++ b/Makefile
@@ -40,7 +40,7 @@ $(outdir)/shellcheck:
cd $(@D)/test && ./testenv $(TESTENVFLAGS) 'cd "$$TMPDIR/destdir" && find \( $(shellcheck.prune) \) -prune -o -not -type d -exec shellcheck $(shellcheck.flags) {} +'
_po_rule = \
-po/%(pkg).pot: $(addsuffix /everything.pot,$(pkg.%(pkg))); \
+$(srcdir)/po/%(pkg).pot: $(addsuffix /dir.pot,$(pkg.%(pkg))); \
cat $^ | msguniq -Fi --to-code=UTF-8 > '$@'
$(eval $(foreach pkg,$(pkgs),\
$(subst %(pkg),$(pkg),$(value _po_rule))$(at.nl)))
diff --git a/build-aux/Makefile.each.tail/20-libretools.mk b/build-aux/Makefile.each.tail/20-libretools.mk
index 4398e2c..8902a26 100644
--- a/build-aux/Makefile.each.tail/20-libretools.mk
+++ b/build-aux/Makefile.each.tail/20-libretools.mk
@@ -22,7 +22,7 @@ endif
# Connect with `files` module ########################################
files.src.gen += $(libretools.src.devtools)
files.out.all += $(filter-out $(files.src),$(libretools.out)) \
- $(if $(strip $(libretools.pots)),everything.pot)
+ $(if $(strip $(libretools.pots)),dir.pot)
files.sys.all += $(addprefix $(bindir)/,$(libretools.out.bins)) \
$(addprefix $(pkgconfdir)/,$(libretools.out.confs)) \
$(addprefix $(pkglibexecdir)/,$(libretools.out.libexecs) $(libretools.out.libs)) \
@@ -52,11 +52,9 @@ $(outdir)/%: $(srcdir)/%.ronn
ronn --roff $(RONNFLAGS) < '$<' > '$@'
$(outdir)/%.html: $(srcdir)/%.ronn
ronn --html $(RONNFLAGS) < '$<' > '$@'
-$(outdir)/%.pot: $(outdir)/% $(topsrcdir)/src/lib/librexgettext
+$(srcdir)/%.pot: $(srcdir)/% $(topsrcdir)/src/lib/librexgettext
$(topsrcdir)/src/lib/librexgettext $(LIBREXGETTEXT_FLAGS) '$<' > '$@'
-$(outdir)/%.pot: $(srcdir)/% $(topsrcdir)/src/lib/librexgettext
- $(topsrcdir)/src/lib/librexgettext $(LIBREXGETTEXT_FLAGS) '$<' > '$@'
-$(outdir)/everything.pot: $(addprefix $(outdir)/,$(addsuffix .pot,$(libretools.pots)))
+$(srcdir)/dir.pot: $(addprefix $(outdir)/,$(addsuffix .pot,$(libretools.pots)))
cat $^ | $(libretools.pofmt) > '$@'
# Install rules ######################################################
diff --git a/build-aux/Makefile.once.head/00-libretools.mk b/build-aux/Makefile.once.head/00-libretools.mk
index 7c1ffef..832649d 100644
--- a/build-aux/Makefile.once.head/00-libretools.mk
+++ b/build-aux/Makefile.once.head/00-libretools.mk
@@ -61,7 +61,7 @@ define mod.libretools.doc
# - Target : `$(outdir)/%.html: $(srcdir)/%.ronn`
# - Target : `$(outdir)/%.pot: $(outdir)/%`
# - Target : `$(outdir)/%.pot: $(srcdir)/%`
-# - Target : `$(outdir)/everything.pot`
+# - Target : `$(srcdir)/dir.pot`
# - Target : `$(outdir)/%.ugly: $(srcdir)/%.in $(srcdir)/%.patch`
# - Target : `$(outdir)/%: $(outdir)/%.ugly
# - Target : `$(DESTDIR)...:`