summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-01-03 12:17:09 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2018-01-03 13:00:32 -0500
commitb8c5c50d5eddd2346e579184305ecfb61d5660a8 (patch)
tree426020576ff7cf3044420752d0e24528e2ea4f38
parent4bd0f69b5e5889158ccc13c64551f6d42da4c3bd (diff)
update for new devtools
-rw-r--r--po/es/librelib.po4
-rw-r--r--po/es/libretools.po4
-rw-r--r--po/es/xbs.po6
-rw-r--r--src/chroot-tools/Makefile4
-rwxr-xr-xsrc/chroot-tools/chcleanup.lib.gen8
-rwxr-xr-xsrc/chroot-tools/libremakepkg1
6 files changed, 16 insertions, 11 deletions
diff --git a/po/es/librelib.po b/po/es/librelib.po
index d50c188..570a9f5 100644
--- a/po/es/librelib.po
+++ b/po/es/librelib.po
@@ -139,10 +139,6 @@ msgstr "hecho"
msgid "Aborting..."
msgstr "Abortando..."
-#: src/lib/common.sh:174 src/lib/common.sh:191
-msgid "{"
-msgstr "{"
-
#: src/lib/common.sh:279 src/lib/common.sh:336
msgid "Multiple packages found:"
msgstr "MĂșltiples paquetes encontrados:"
diff --git a/po/es/libretools.po b/po/es/libretools.po
index d8cd763..d424782 100644
--- a/po/es/libretools.po
+++ b/po/es/libretools.po
@@ -944,6 +944,10 @@ msgstr ""
msgid "let this `builduser` call `sudo pacman` without a password."
msgstr ""
+#: src/chroot-tools/libremakepkg:149
+msgid "set `keyserver-options` in `~builduser/.gnupg/gpg.conf`"
+msgstr ""
+
#: src/chroot-tools/libremakepkg:150
msgid "copy the user's GnuPG pubring to be the `builduser`'s pubring"
msgstr ""
diff --git a/po/es/xbs.po b/po/es/xbs.po
index 729c470..e0c5d7d 100644
--- a/po/es/xbs.po
+++ b/po/es/xbs.po
@@ -49,11 +49,7 @@ msgstr "Copiando %s a %s"
msgid "Releasing package"
msgstr "Publicando paquete"
-#: src/xbs-abs/commitpkg:8
-msgid "Removing %s and %s"
-msgstr "Emilinando %s y %s"
-
-#: src/xbs-abs/commitpkg:18
+#: src/xbs-abs/commitpkg:8 src/xbs-abs/commitpkg:17
msgid "Removing %s"
msgstr "Eliminando %s"
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index c39b4f5..e3274e0 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -14,8 +14,8 @@ $(srcdir)/makechrootpkg.sh.in: $(srcdir)/makechrootpkg.in
$(outdir)/chcleanup: $(srcdir)/chcleanup.in $(outdir)/chcleanup.lib
m4 -I$(@D) -P $< | $(libretools.edit) | install -m755 /dev/stdin $@
-$(outdir)/chcleanup.lib: $(call at.path,$(topoutdir)/src/lib/common.sh) $(outdir)/Makefile
- bash -c '. $<; declare -f _l plain msg msg2 error' > $@
+$(outdir)/chcleanup.lib: $(srcdir)/chcleanup.lib.gen $(call at.path,$(topoutdir)/src/lib/common.sh)
+ $(abspath $^) > $@
$(outdir)/distcc-tool.pot: LIBREXGETTEXT_FLAGS+=--simple=errusage
diff --git a/src/chroot-tools/chcleanup.lib.gen b/src/chroot-tools/chcleanup.lib.gen
new file mode 100755
index 0000000..71dc327
--- /dev/null
+++ b/src/chroot-tools/chcleanup.lib.gen
@@ -0,0 +1,8 @@
+#!/usr/bin/env bash
+set -e
+
+commonsh=$1
+
+echo '. /usr/share/makepkg/util.sh'
+. "$commonsh"; declare -f _l _p
+sed -n '/^eval/,/^\S/p' "$commonsh"
diff --git a/src/chroot-tools/libremakepkg b/src/chroot-tools/libremakepkg
index 21f5619..d8d935c 100755
--- a/src/chroot-tools/libremakepkg
+++ b/src/chroot-tools/libremakepkg
@@ -146,6 +146,7 @@ usage() {
bullet 'create a `builduser` with the same numeric UID as the
invoking $SUDO_USER.'
bullet 'let this `builduser` call `sudo pacman` without a password.'
+ bullet 'set `keyserver-options` in `~builduser/.gnupg/gpg.conf`'
bullet "copy the user's GnuPG pubring to be the \`builduser\`'s pubring"
bullet 'add a pacman repositoriy of locally built packages'
echo