summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2021-01-22 21:17:22 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2021-07-26 19:20:09 -0400
commit13a7a894c96dbbcacbcbabbe831b274eaa1229ea (patch)
tree2f0cdc78742eb3e82e418997c8979f07dbee93ab
parent8a258bf49939b9a92e8081e4bf0cc0f9adcaa972 (diff)
housekeeping
-rwxr-xr-xsrc/librefetch/librefetch12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 394c187..6767a6c 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -208,11 +208,15 @@ doit() {
fi
# Mode: create #########################################################
+ #
+ # This is where the 'mksource' magic is initiated.
+ # The recursive `makepkg` invokation processes a modified PKGBUILD (per PKGBUILD_APPEND).
if [[ $mode =~ create ]]; then
local base_dst=${dst%.part}
local suffix=${dst#"$base_dst"}
- local srcball_not_found_msg="Libre source-ball not found. Attempting to create it from upstream sources."
+ local src_missing_msg="Libre source not found. Attempting to create it from upstream sources."
+ local done_msg="Libre source created successfully"
if [[ $base_dst == *.sig ]]; then
# recurse to create the libre source-ball, if it does not yet exist
@@ -220,7 +224,7 @@ doit() {
if ! [[ -e ${base_dst%.sig} ]]; then
extra_opts=("${src%.sig}" "${base_dst%.sig}")
- msg2 "${srcball_not_found_msg}"
+ msg2 "${src_missing_msg}"
doit || exit
fi
# FIXME: there is a note about this signature in usage()
@@ -233,8 +237,8 @@ doit() {
export pkg_file=$dst
cd "$BUILDFILEDIR"
- msg2 "${srcball_not_found_msg}"
- "$makepkg" "${makepkg_opts[@]}" -p "$srcbuild" >&2 || exit
+ msg2 "${src_missing_msg}"
+ "$makepkg" "${makepkg_opts[@]}" -p "$srcbuild" >&2 && msg2 "${done_msg}" || exit
fi
fi
}