summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2021-01-22 21:17:22 -0500
committerAndreas Grapentin <andreas@grapentin.org>2022-01-18 17:31:56 +0100
commitcf00ae789e8388c2f2246019e34437081f148b2d (patch)
tree422051bc1612c8260929a88c81b645d86494a380
parentdebc441384faaee6343bbc763d0e7a276b793dd8 (diff)
housekeeping
-rwxr-xr-xsrc/librefetch/librefetch12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 394c187..6767a6c 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -208,11 +208,15 @@ doit() {
fi
# Mode: create #########################################################
+ #
+ # This is where the 'mksource' magic is initiated.
+ # The recursive `makepkg` invokation processes a modified PKGBUILD (per PKGBUILD_APPEND).
if [[ $mode =~ create ]]; then
local base_dst=${dst%.part}
local suffix=${dst#"$base_dst"}
- local srcball_not_found_msg="Libre source-ball not found. Attempting to create it from upstream sources."
+ local src_missing_msg="Libre source not found. Attempting to create it from upstream sources."
+ local done_msg="Libre source created successfully"
if [[ $base_dst == *.sig ]]; then
# recurse to create the libre source-ball, if it does not yet exist
@@ -220,7 +224,7 @@ doit() {
if ! [[ -e ${base_dst%.sig} ]]; then
extra_opts=("${src%.sig}" "${base_dst%.sig}")
- msg2 "${srcball_not_found_msg}"
+ msg2 "${src_missing_msg}"
doit || exit
fi
# FIXME: there is a note about this signature in usage()
@@ -233,8 +237,8 @@ doit() {
export pkg_file=$dst
cd "$BUILDFILEDIR"
- msg2 "${srcball_not_found_msg}"
- "$makepkg" "${makepkg_opts[@]}" -p "$srcbuild" >&2 || exit
+ msg2 "${src_missing_msg}"
+ "$makepkg" "${makepkg_opts[@]}" -p "$srcbuild" >&2 && msg2 "${done_msg}" || exit
fi
fi
}