summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2023-12-19 14:32:19 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2024-01-01 20:33:08 -0500
commit2548a8829efb146f57a382a30df899a5ae925573 (patch)
tree993dadffc893bab34da5cffc713c6913aa99525f
parentb15c933675a6157f6ab22ee8b6a7214002c6b5fd (diff)
[conf.sh.in]: update known_hash_algos
-rw-r--r--src/lib/conf.sh.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/lib/conf.sh.in b/src/lib/conf.sh.in
index 03f3220..35a537b 100644
--- a/src/lib/conf.sh.in
+++ b/src/lib/conf.sh.in
@@ -238,8 +238,11 @@ unset_PKGBUILD() {
done
}
- # This line is taken from the makepkg source
- local known_hash_algos=('md5' 'sha1' 'sha224' 'sha256' 'sha384' 'sha512')
+
+ # These are taken from makepkg::util/schema.sh)
+ local known_hash_algos=( $( LIBRARY=${LIBRARY:-'/usr/share/makepkg'} ; \
+ source "$LIBRARY/util/schema.sh" ; \
+ printf ${known_hash_algos[*]} ) )
# From the "OPTIONS AND DIRECTIVES" section (in order of mention)
unset -v pkgname pkgver