summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2023-12-25 20:50:08 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2024-01-04 16:08:54 -0500
commitb10085cc9e6eab5839cadc6d8a669f39dc5f6571 (patch)
tree3054d4343cdf9f234c54fdaaf7a8d47ad31e6225
parent9855021078f48eba4405275dbe174e714bd4f056 (diff)
normalize `source` calls
-rw-r--r--build-aux/Makefile.once.head/00-libretools.mk2
-rw-r--r--src/lib/conf.sh.in1
2 files changed, 1 insertions, 2 deletions
diff --git a/build-aux/Makefile.once.head/00-libretools.mk b/build-aux/Makefile.once.head/00-libretools.mk
index cd5213d..00d43d0 100644
--- a/build-aux/Makefile.once.head/00-libretools.mk
+++ b/build-aux/Makefile.once.head/00-libretools.mk
@@ -95,7 +95,7 @@ files.groups = all $(libretools.groups)
# Magic for doing @variable@ replacement in files
libretools.edit = sed \
-e 's|^\#!\s*/bin/bash|\#!/usr/bin/env bash|' \
- -e 's|m4_include(lib/\(.*\))|. "$$(librelib \1)"|' \
+ -e 's|m4_include(lib/\(.*\))|source "$$(librelib \1)"|' \
$(foreach v,$(patsubst $(var.)%,%,$(filter $(var.)%,$^)), -e 's|@$(v)@|$($(v))|g' )
# Usage <INPUT $(libretools.pofmt) >OUTPUT
diff --git a/src/lib/conf.sh.in b/src/lib/conf.sh.in
index 5f72917..91f86a6 100644
--- a/src/lib/conf.sh.in
+++ b/src/lib/conf.sh.in
@@ -42,7 +42,6 @@ readonly LIBRETOOLS_CONF_SH=/usr/lib/libretools/conf.sh # this file
readonly PACMAN_DEFS_DIR=/usr/share/pacman/defaults
# supported architectures
-
readonly SUPPORTED_ARCHES=( armv7h i686 x86_64 )
readonly EXPERIMENTAL_ARCHES=( aarch64 ppc64le riscv64 )
readonly ALL_ARCHES=( ${SUPPORTED_ARCHES[*]} ${EXPERIMENTAL_ARCHES[*]} )