summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2022-08-28 21:54:55 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2023-12-14 14:56:05 -0500
commitf12bb54567d29c65376ad6e2a7173a22fedaa6d7 (patch)
treed54087de9e2ddefe7e434145dfed94ccbdf2bb60
parent622e234868b924f8e5cbc3c5122cd4b1c4b264ce (diff)
temp fix - host<->chroot glibc mismatch
-rw-r--r--src/chroot-tools/chcleanup.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/chroot-tools/chcleanup.in b/src/chroot-tools/chcleanup.in
index 2cb39af..1d77ede 100644
--- a/src/chroot-tools/chcleanup.in
+++ b/src/chroot-tools/chcleanup.in
@@ -75,6 +75,15 @@ WHITELIST_PKGS=() # DEBUG: normally empty - optional packages, possibly insane
fakeroot_pkg=fakeroot$( [[ "$(uname -m)" == 'armv7l' ]] && echo '-tcp' )
CHROOTPKG=( ${CHROOTPKG[*]/fakeroot/${fakeroot_pkg}/} )
+# FIXME: host<->chroot glibc mismatch
+WHITELIST_PKGS+=( glibc-linux4 ) # BR #3038
+# $ wget https://repo.archlinuxcn.org/x86_64/glibc-linux4-2.33-4-x86_64.pkg.tar.zst.sig
+# $ wget https://repo.archlinuxcn.org/x86_64/glibc-linux4-2.33-4-x86_64.pkg.tar.zst
+# $ pacman-key --verify glibc-linux4-2.33-4-x86_64.pkg.tar.zst.sig
+# $ sudo librechroot -n autobuilder install-file glibc-linux4-2.33-4-x86_64.pkg.tar.zst
+# $ sudo cp glibc-linux4-2.33-4-x86_64.pkg.tar.zst* /var/lib/archbuild/autobuilder/bill-auger/
+# $ sudo librechroot -n autobuilder enter
+
# If we're running makepkg
if [[ -f ./PKGBUILD ]]; then
if [[ ! -f ./.SRCINFO || ./PKGBUILD -nt ./.SRCINFO ]]; then