summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-02 16:07:51 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-05-02 16:07:51 -0400
commit2c6e781d121b12f6d26b52ed0b2fd13551d7dba8 (patch)
treef37f3355049dd4281a71d711247c12a17a6e47a7
parent8dc10faef5e2892fadf02cc523b40ec09883c48c (diff)
fix the Makefiles
-rw-r--r--Makefile5
-rw-r--r--src/devtools/Makefile6
2 files changed, 4 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 69a9dc8..e5b38b1 100644
--- a/Makefile
+++ b/Makefile
@@ -15,13 +15,10 @@ docdir=$(datarootdir)/doc
################################################################################
-# these are directories
-pseudo-packages=abslibre-tools chroot-tools devtools fullpkg lib mips64el-tools toru
-
# these are the resulting packages
packages=libretools libretools-mips64el
# and which directories they contains
-libretools=abslibre-tools lib chroot-tools devtools fullpkg toru misc
+libretools=abslibre-tools chroot-tools devtools fullpkg lib librefetch misc toru
libretools-mips64el=mips64el-tools
################################################################################
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index d78e5f3..453f843 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -80,15 +80,15 @@ install: \
$(DESTDIR)$(pkgdatadir)/common.sh \
$(DESTDIR)$(pkgdatadir)/makechrootpkg.sh
-$(DESTDIR)$(PREFIX)/sbin/%: %
+$(DESTDIR)$(sbindir)/%: %
install -Dm755 $< $@
-$(DESTDIR)$(PREFIX)/bin/%: %
+$(DESTDIR)$(bindir)/%: %
install -Dm755 $< $@
$(DESTDIR)$(pkgdatadir)/%: lib/%
install -Dm644 $< $@
-$(DESTDIR)$(PREFIX)/bin/find-libprovides:
+$(DESTDIR)$(bindir)/find-libprovides:
install -d $(@D)
ln -sf find-libdeps $@