summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-09-29 12:53:47 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-29 18:48:52 -0400
commit3473a80a47f2cadc729f3be05fa7485ae5b12e22 (patch)
tree11389bfb491fb51a09c254c7c8f9142b18a68b42
parent76ddd033cdd42887be4a0723e613df0f9e9c4b6a (diff)
Strip trailing whitespace everywhere.
find * -type f -not -name '*.patch' -exec sed -i -r 's/\s+$//' {} +
-rw-r--r--doc/treepkg.md10
-rw-r--r--doc/workflows.md4
-rwxr-xr-xsrc/aur24
-rwxr-xr-xsrc/librefetch/librefetch2
-rwxr-xr-xsrc/mips64el-tools/mipsrelease2
-rwxr-xr-xsrc/treepkg2
-rw-r--r--test/is_built-test.sh4
7 files changed, 24 insertions, 24 deletions
diff --git a/doc/treepkg.md b/doc/treepkg.md
index 7f7ece1..1e30e33 100644
--- a/doc/treepkg.md
+++ b/doc/treepkg.md
@@ -67,18 +67,18 @@ Your HOOKLOCALRELEASE script should look like this:
source PKGBUILD
unset build package check
-
+
fullver=$(full_version ${epoch:-0} ${pkgver} ${pkgrel})
pkgs=()
-
+
# Generate canonical package paths
msg "Adding packages to [stage3]..."
for name in ${pkgname[@]}; do
msg2 "${name} ${fullver}"
pkgs+=("${PKGDEST}/${name}-${fullver}-*.pkg.tar.*")
done
-
- # Add the packages to a local
+
+ # Add the packages to a local
repo-add ${PKGDEST}/stage3.db.tar.gz ${pkgs[@]}
# Stage the packages for later releasing
@@ -109,7 +109,7 @@ current one. Thus this will become the build path:
> a really long build tree with some circular dependencies you may find
> packages buried several times and queued to build before their actuals deps.
-## Tips
+## Tips
`treepkg` accepts two arguments: 1) the temporary work dir and 2) the next
depth level it should use (if current equals 0, it'll pass 1). You don't need
diff --git a/doc/workflows.md b/doc/workflows.md
index f55ae7e..fe3c12e 100644
--- a/doc/workflows.md
+++ b/doc/workflows.md
@@ -28,7 +28,7 @@ This is how the chroot is configured:
* Bind mount /var/cache/pacman/pkg to /chroot/var/cache/pacman/pkg
* Put these on system's fstab so I don't have to do it everytime
-
+
* Configure makepkg.conf to PKGDEST=CacheDir and SRCDEST to something on my home.
Workflow:
@@ -50,7 +50,7 @@ What this allows:
* Building many packages in a row without recreating a chroot for every one of
them.
-
+
* Knowing that any change you made to the chroot stays as you want (no one
touches your makepkg.conf)
diff --git a/src/aur b/src/aur
index 08de67e..2c1fe6d 100755
--- a/src/aur
+++ b/src/aur
@@ -3,20 +3,20 @@
# Copyright 2010 Nicolás Reynolds
# Copyright 2013 Luke Shumaker
#
-# This file is part of Parabola.
+# This file is part of Parabola.
#
-# Parabola is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-
-# Parabola is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
#
-# You should have received a copy of the GNU General Public License
-# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
. libremessages
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 19942ef..52aea9a 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -1,6 +1,6 @@
#!/usr/bin/env bash
# librefetch
-#
+#
# Copyright 2013 Luke Shumaker <lukeshu@sbcglobal.net>
#
# This file is part of Parabola.
diff --git a/src/mips64el-tools/mipsrelease b/src/mips64el-tools/mipsrelease
index a8c2db6..ffa223d 100755
--- a/src/mips64el-tools/mipsrelease
+++ b/src/mips64el-tools/mipsrelease
@@ -5,7 +5,7 @@
# Called by HOOKLOCALRELEASE
# $1 repo
-# $2+ packages
+# $2+ packages
. libremessages
. $(librelib conf.sh)
diff --git a/src/treepkg b/src/treepkg
index 8219ce6..5c1312d 100755
--- a/src/treepkg
+++ b/src/treepkg
@@ -97,7 +97,7 @@ unset build package >/dev/null 2>&1
for _pkg in "${pkgname[@]}"; do
unset package_${_pkg} >/dev/null 2>&1 || true
done
-##
+##
# Get useful values
pkgbase="${pkgbase:-${pkgname[0]}}"
diff --git a/test/is_built-test.sh b/test/is_built-test.sh
index 62847e5..c547b93 100644
--- a/test/is_built-test.sh
+++ b/test/is_built-test.sh
@@ -37,7 +37,7 @@ it_succeeds_with_1_arg() {
it_returns_1_for_non_existent_package() {
is_built phony-ne-package 100 >$tmpdir/stdout 2>$tmpdir/stderr || stat=$?
- [[ $stat == 1 ]]
+ [[ $stat == 1 ]]
[[ -z "$(cat $tmpdir/stdout)" ]]
[[ -z "$(cat $tmpdir/stderr)" ]]
}
@@ -46,7 +46,7 @@ it_returns_1_for_future_packages() {
# If emacs ever goes rapid release, we might need to change this :P
is_built emacs 100 >$tmpdir/stdout 2>$tmpdir/stderr || stat=$?
- [[ $stat == 1 ]]
+ [[ $stat == 1 ]]
[[ -z "$(cat $tmpdir/stdout)" ]]
[[ -z "$(cat $tmpdir/stderr)" ]]
}