summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-10-15 12:17:36 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-10-15 12:20:40 -0400
commitff0a11e6ccd17ce058685ae47ee4174d31bc673a (patch)
tree154746cd7d140a5132fcc1bddff852f5ab387fcb
parent5fd5b23c74b11920bc577163d4890b04e3bc200f (diff)
Makefile: Don't generate .pot files for texinfo targets
-rw-r--r--build-aux/Makefile.once.head/00-libretools.mk4
-rw-r--r--po/Makefile2
2 files changed, 4 insertions, 2 deletions
diff --git a/build-aux/Makefile.once.head/00-libretools.mk b/build-aux/Makefile.once.head/00-libretools.mk
index b4d7848..cd5213d 100644
--- a/build-aux/Makefile.once.head/00-libretools.mk
+++ b/build-aux/Makefile.once.head/00-libretools.mk
@@ -38,6 +38,7 @@ define mod.libretools.doc
# - `libretools.edit`
# - `libretools.pofmt`
# - Source information
+# - Global variable : `libretools.groups`
# - Directory variable : `libretools.pkg = libretools`
# - Directory variable : `libretools.src`
# - Directory variable : `libretools.src.exec`
@@ -80,7 +81,8 @@ mod.quote.doc := $(value mod.quote.doc)
# Configure how Autothing modules work ###############################
gitfiles.file = .srcfiles.mk
-files.groups = all libretools librelib gitget
+libretools.groups = libretools librelib gitget
+files.groups = all $(libretools.groups)
# Boilerplate ########################################################
.PHONY: FORCE
diff --git a/po/Makefile b/po/Makefile
index d1d72a0..e3de867 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -1,7 +1,7 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
-domains = $(filter-out all,$(files.groups))
+domains = $(filter-out all,$(libretools.groups))
locales := $(filter-out .,$(sort $(patsubst %/,%,$(dir $(files.src.src)))))
files.src.gen += $(addsuffix .pot,$(domains))