summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-07-08 22:08:04 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-07-08 22:08:04 -0400
commitbcc12b176fc19070aa16940ff4840830bc2ecd59 (patch)
treed106ea6a95d4fa20d8ccfce16d797df4ba425d9b /Makefile
parentafc6093ea5b87d2d4c870cef7ef66548d3d576ba (diff)
Makefile: add support for compiling and installing localizations
This means that the new `po/files.generate` target can be used to build the `.pot` files without doing anything else; we can stop requiring translators to install ruby-ronn. It also means that we can put the `.pot` files in the source tarball, to make it even easier for translators. Unfortunately, it does add the extra step of having to create another symlink when adding a new locale.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 444a669..f6b78e9 100644
--- a/Makefile
+++ b/Makefile
@@ -54,6 +54,6 @@ libretools.out.confs =
libretools.out = $(foreach pkg,$(pkgs),po/$(pkg).pot)
files.src.gen += .srcversion-libretools.mk .srcversion-devtools.mk
-nested.subdirs = $(foreach pkg,$(pkgs),$(pkg.$(pkg)))
+nested.subdirs = $(foreach pkg,$(pkgs),$(pkg.$(pkg))) po
include $(topsrcdir)/build-aux/Makefile.tail.mk