summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-03-27 19:44:34 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-03-27 21:27:19 -0400
commit086df91f23d1f3486725353ffe1630da8f9c8f5c (patch)
treec583bb8b5ffcfd915b02a44ef9799bd47f2bbbc5 /Makefile
parent36f875645e36bf1ff015cc7d3441de2e1714b6fc (diff)
Makefile: Use files.groups instead of nested.subdirs to split the package
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile43
1 files changed, 8 insertions, 35 deletions
diff --git a/Makefile b/Makefile
index 9992d49..1252b64 100644
--- a/Makefile
+++ b/Makefile
@@ -1,29 +1,15 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
-# these are the resulting packages
-pkgs=libretools librelib gitget xbs
-# and which directories they contain
-pkg.libretools=\
- src \
- src/abslibre-tools \
- src/chroot-tools \
- src/devtools \
- src/librefetch \
- src/toru
-pkg.librelib=src/lib
-pkg.gitget=src/gitget
-pkg.xbs=\
- src/xbs \
- src/xbs-abs \
- src/xbs-abslibre
+libretools.out.mans =
+libretools.out.bins =
+libretools.out.libexecs =
+libretools.out.libs =
+libretools.out.docs =
+libretools.out.confs =
-define _pkg_rule
-%(verb)-%(pkg): $(addsuffix /%(verb),$(pkg.%(pkg)))
-.PHONY: %(verb)-%(pkg)
-endef
-$(eval $(foreach verb,$(nested.targets),$(foreach pkg,$(pkgs),\
- $(subst %(verb),$(verb),$(subst %(pkg),$(pkg),$(value _pkg_rule)))$(at.nl))))
+files.src.gen += .srcversion-libretools.mk .srcversion-devtools.mk
+nested.subdirs = src po
$(outdir)/check:
cd $(@D)/test && ./testenv $(TESTENVFLAGS) roundup
@@ -39,17 +25,4 @@ $(outdir)/shellcheck: private shellcheck.prune += -o -type f -name source.sh.gen
$(outdir)/shellcheck:
cd $(@D)/test && ./testenv $(TESTENVFLAGS) 'cd "$$TMPDIR/destdir" && find \( $(shellcheck.prune) \) -prune -o -not -type d -exec shellcheck $(shellcheck.flags) {} +'
-$(eval $(foreach pkg,$(pkgs),\
- $(call at.path,$(srcdir)/po/$(pkg).pot): $(call at.addprefix,$(topsrcdir),$(addsuffix /dir.pot,$(pkg.$(pkg))))$(at.nl)))
-
-libretools.out.mans =
-libretools.out.bins =
-libretools.out.libexecs =
-libretools.out.libs =
-libretools.out.docs =
-libretools.out.confs =
-
-files.src.gen += .srcversion-libretools.mk .srcversion-devtools.mk
-nested.subdirs = $(foreach pkg,$(pkgs),$(pkg.$(pkg))) po
-
include $(topsrcdir)/build-aux/Makefile.tail.mk