summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-06-09 15:55:33 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-06-09 15:55:33 -0400
commitd330445fb7f84748e70e67ca5bc44ce0a1a258f7 (patch)
tree0c1c957298635b7ba0ff69c2fe76af647304a631 /Makefile
parentf579b669d45c02b39474827f12522ff4afa6cf4a (diff)
Work with the new version of autothing.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 5be5195..0e9caa2 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/config.mk
-include $(topsrcdir)/automake.head.mk
+include $(topsrcdir)/build-aux/Makefile.head.mk
# these are the resulting packages
packages=libretools librelib gitget xbs
@@ -31,9 +31,11 @@ po/%(package).pot: $(addsuffix /everything.pot,$(%(package))); \
$(foreach package,$(packages),$(eval $(subst %(package),$(package),$(value _po_rule))))
pots =
-am_out_files += $(foreach package,$(packages),po/$(package).pot)
-am_clean_files += .var.*
-am_gen_files += .srcversion-libretools.mk .srcversion-devtools.mk
-am_subdirs = src $(foreach package,$(packages),$($(package)))
+std.out_files += $(foreach package,$(packages),po/$(package).pot)
+std.clean_files += .var.*
+std.gen_files += .srcversion-libretools.mk .srcversion-devtools.mk
+at.subdirs = src $(foreach package,$(packages),$($(package)))
+detect-ignore-md += HACKING/%
+detect-ignore-exec += build-aux/%
-include $(topsrcdir)/automake.tail.mk
+include $(topsrcdir)/build-aux/Makefile.tail.mk