summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-01-03 12:34:53 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2018-01-03 13:34:08 -0500
commit99ba7e29afaccb5b47ada8c2d8e0b0f98de91936 (patch)
tree98c0ed639758e95601e9e696e14fa7d8ab9fa9dc /Makefile
parentb8c5c50d5eddd2346e579184305ecfb61d5660a8 (diff)
Makefile: don't let paths in .pot files depend on where `make` was called
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5d7ece2..9992d49 100644
--- a/Makefile
+++ b/Makefile
@@ -40,7 +40,7 @@ $(outdir)/shellcheck:
cd $(@D)/test && ./testenv $(TESTENVFLAGS) 'cd "$$TMPDIR/destdir" && find \( $(shellcheck.prune) \) -prune -o -not -type d -exec shellcheck $(shellcheck.flags) {} +'
$(eval $(foreach pkg,$(pkgs),\
- $(srcdir)/po/$(pkg).pot: $(addsuffix /dir.pot,$(pkg.$(pkg)))$(at.nl)))
+ $(call at.path,$(srcdir)/po/$(pkg).pot): $(call at.addprefix,$(topsrcdir),$(addsuffix /dir.pot,$(pkg.$(pkg))))$(at.nl)))
libretools.out.mans =
libretools.out.bins =