summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-04-20 22:47:08 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-05-04 14:27:15 -0400
commitbb97cfc85d9b711b517985abbd9832bff9c4b37a (patch)
tree20d328819279d96e987d5212ea39a97604b9e2c2 /Makefile
parentb245def72cd67e6475651b12e3313d8011b128bc (diff)
shellcheck directives
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5e83abc..e7b35e4 100644
--- a/Makefile
+++ b/Makefile
@@ -28,6 +28,17 @@ $(eval $(foreach verb,$(nested.targets),$(foreach pkg,$(pkgs),\
$(outdir)/check:
cd $(@D)/test && ./testenv $(TESTENVFLAGS) roundup
+$(outdir)/shellcheck: private shellcheck.flags = --exclude=1090,1091,2016,2059,2064,2164,2191
+$(outdir)/shellcheck: private shellcheck.prune = -false
+$(outdir)/shellcheck: private shellcheck.prune += -o -type d -name doc
+$(outdir)/shellcheck: private shellcheck.prune += -o -type d -name man
+$(outdir)/shellcheck: private shellcheck.prune += -o -type f -name indent
+$(outdir)/shellcheck: private shellcheck.prune += -o -type f -name Makefile
+$(outdir)/shellcheck: private shellcheck.prune += -o -type f -name makepkg.gen
+$(outdir)/shellcheck: private shellcheck.prune += -o -type f -name source.sh.gen
+$(outdir)/shellcheck:
+ cd $(@D)/test && ./testenv $(TESTENVFLAGS) 'cd "$$TMPDIR/destdir" && find \( $(shellcheck.prune) \) -prune -o -not -type d -exec shellcheck $(shellcheck.flags) {} +'
+
_po_rule = \
po/%(pkg).pot: $(addsuffix /everything.pot,$(pkg.%(pkg))); \
cat $^ | msguniq -Fi --to-code=UTF-8 > '$@'