summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 20:12:32 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 20:21:36 -0400
commite3d7fbca888e07f02c5867dd1e50393247a066b7 (patch)
treeba8c5bac162127ceab0eacb2a6f33de759c62943 /Makefile
parent371a7e29d5718cadbe7cd1830050487f60946266 (diff)
po: add pot headers
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index f6b78e9..5d7ece2 100644
--- a/Makefile
+++ b/Makefile
@@ -39,11 +39,8 @@ $(outdir)/shellcheck: private shellcheck.prune += -o -type f -name source.sh.gen
$(outdir)/shellcheck:
cd $(@D)/test && ./testenv $(TESTENVFLAGS) 'cd "$$TMPDIR/destdir" && find \( $(shellcheck.prune) \) -prune -o -not -type d -exec shellcheck $(shellcheck.flags) {} +'
-_po_rule = \
-$(srcdir)/po/%(pkg).pot: $(addsuffix /dir.pot,$(pkg.%(pkg))); \
- cat $^ | msguniq -Fi --to-code=UTF-8 > '$@'
$(eval $(foreach pkg,$(pkgs),\
- $(subst %(pkg),$(pkg),$(value _po_rule))$(at.nl)))
+ $(srcdir)/po/$(pkg).pot: $(addsuffix /dir.pot,$(pkg.$(pkg)))$(at.nl)))
libretools.out.mans =
libretools.out.bins =
@@ -51,7 +48,6 @@ libretools.out.libexecs =
libretools.out.libs =
libretools.out.docs =
libretools.out.confs =
-libretools.out = $(foreach pkg,$(pkgs),po/$(pkg).pot)
files.src.gen += .srcversion-libretools.mk .srcversion-devtools.mk
nested.subdirs = $(foreach pkg,$(pkgs),$(pkg.$(pkg))) po