summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-08-25 14:18:14 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-11 15:43:30 -0400
commitf3030244f64699021ec0d9cd9e4b4d67244d9df1 (patch)
tree2a2ed877b15799cbc33111528e286e6796c45e78 /Makefile
parentdabf1a9cf520d725f8eb767bb0112990f99fde05 (diff)
Make common-devtools.mk unnecessary. Move devtools chroot stuff into chroot-tools
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 75d1771..3f95e6e 100644
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,7 @@ all: PHONY build
copy: PHONY $(addprefix copy-, $(packages))
build: PHONY $(addprefix build-, $(packages))
install: PHONY $(addprefix install-,$(packages))
+clean: PHONY $(addprefix clean-, $(packages))
check:
@cd test && ./testenv $(TESTENVFLAGS) roundup
@@ -33,11 +34,14 @@ check:
$(MAKE) -C $*
%/install: PHONY %
$(MAKE) -C $* install
+%/clean: PHONY %
+ $(MAKE) -C $* clean
.SECONDEXPANSION:
$(addprefix copy-, $(packages)): copy-%: PHONY $$(addsuffix /copy, $$($$*))
$(addprefix build-, $(packages)): build-%: PHONY $$(addsuffix /build, $$($$*))
$(addprefix install-,$(packages)): install-%: PHONY $$(addsuffix /install,$$($$*))
+$(addprefix clean-, $(packages)): clean-%: PHONY $$(addsuffix /clean, $$($$*))
################################################################################