summaryrefslogtreecommitdiff
path: root/aur
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-05-12 14:54:49 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-05-12 14:54:49 -0500
commit92d1fe72f7ec9deea70772aa41ec1e29072599c8 (patch)
tree25680b44bebd74dbf26f52a3723c7c0e9b3b441b /aur
parentfe0d876c4930180e6604b754cb8287ae042127da (diff)
little fix
Diffstat (limited to 'aur')
-rwxr-xr-xaur6
1 files changed, 4 insertions, 2 deletions
diff --git a/aur b/aur
index 38b2e2e..44ac650 100755
--- a/aur
+++ b/aur
@@ -19,13 +19,15 @@ for _pkg in ${@}; do
source PKGBUILD
pkgbuild-check-nonfree || {
- warning "This PKGBUILD links to known unfree packages"
+ if [ $? -eq 15 ]; then
+ warning "This PKGBUILD links to known unfree packages"
+ fi
}
msg2 "Checking license..."
free=0
for _license in ${license[@]}; do
- if ! -d /usr/share/licenses/common/$_license; then
+ if [ ! -d /usr/share/licenses/common/$_license ]; then
warning "License $_license is not a common license"
free=1
fi