summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-02-15 18:55:25 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2017-04-11 13:02:27 -0400
commit74067d389c204cd40906980391680724380667c0 (patch)
tree654f7aaed07e8fe019893337256929db87a017a1 /build-aux
parent2e798795833af72ba0618f5577f15488b201b0fa (diff)
Expect devtools files to already be patched.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/Makefile.each.tail/20-libretools.mk10
-rw-r--r--build-aux/Makefile.once.head/00-libretools.mk11
2 files changed, 0 insertions, 21 deletions
diff --git a/build-aux/Makefile.each.tail/20-libretools.mk b/build-aux/Makefile.each.tail/20-libretools.mk
index c498396..1a6dc82 100644
--- a/build-aux/Makefile.each.tail/20-libretools.mk
+++ b/build-aux/Makefile.each.tail/20-libretools.mk
@@ -59,16 +59,6 @@ $(outdir)/%.pot: $(srcdir)/% $(topsrcdir)/src/lib/librexgettext
$(outdir)/everything.pot: $(addprefix $(outdir)/,$(addsuffix .pot,$(libretools.pots)))
cat $^ | $(libretools.pofmt) > '$@'
-# If we have a .patch file, the flow is:
-# $(devtoolsdir)/%.in -> %.in + %.patch -> %.ugly -> %
-_do_patch = $(filter $(patsubst %.patch,%,$(filter %.patch,$(libretools.src.git))),$(patsubst %.in,%,$(libretools.src.devtools)))
-$(outdir)/%.ugly: $(srcdir)/%.in $(srcdir)/%.patch
- cp -T $< $@
- patch $@ $(<D)/$*.patch
-$(sort $(addprefix $(outdir)/,$(_do_patch))): $(outdir)/%: $(outdir)/%.ugly
- @echo 'EDIT < $< > $@'; $(libretools.edit) < '$<' | install -T -m$(if $(_is_executable),755,644) /dev/stdin '$@'
- @echo 'INDENT $@'; $(call libretools.indent,$@)
-
# Install rules ######################################################
$(DESTDIR)$(pkgconfdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'
$(DESTDIR)$(pkgdocdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'
diff --git a/build-aux/Makefile.once.head/00-libretools.mk b/build-aux/Makefile.once.head/00-libretools.mk
index 8497d68..1f2957d 100644
--- a/build-aux/Makefile.once.head/00-libretools.mk
+++ b/build-aux/Makefile.once.head/00-libretools.mk
@@ -37,7 +37,6 @@ define mod.libretools.doc
# - `var`
# - Shell commands (Global variables)
# - `libretools.edit`
-# - `libretools.indent`
# - `libretools.pofmt`
# - Source information
# - Directory variable : `libretools.src`
@@ -93,16 +92,6 @@ libretools.edit = sed \
-e 's|m4_include(lib/\(.*\))|. "$$(librelib \1)"|' \
$(foreach v,$(patsubst $(var.)%,%,$(filter $(var.)%,$^)), -e 's|@$(v)@|$($(v))|g' )
-# Usage: $(call libretools.indent,FILENAME)
-# Command to auto-indent a file.
-libretools.indent = emacs --batch $1 \
- --eval '(setq make-backup-files nil)' \
- --eval '(setq sh-basic-offset 8)' \
- --eval '(defun sh-smie-sh-rules--fix (args) "fix bug in Emacs 24 sh-script.el" (if (equal args (list :after "then")) (list :after "if") args))' \
- --eval "(advice-add 'sh-smie-sh-rules :filter-args \#'sh-smie-sh-rules--fix)" \
- --eval '(indent-region (point-min) (point-max) nil)' \
- -f save-buffer &>/dev/null
-
# Usage <INPUT $(libretools.pofmt) >OUTPUT
# Normalize a .po(t) file
libretools.pofmt = msguniq -Fi --to-code=UTF-8