summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-06-09 15:55:33 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-06-09 15:55:33 -0400
commitd330445fb7f84748e70e67ca5bc44ce0a1a258f7 (patch)
tree0c1c957298635b7ba0ff69c2fe76af647304a631 /build-aux
parentf579b669d45c02b39474827f12522ff4afa6cf4a (diff)
Work with the new version of autothing.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/Makefile.each.head/20-libretools.mk35
-rw-r--r--build-aux/Makefile.each.tail/20-libretools.mk89
-rw-r--r--build-aux/Makefile.once.head/20-libretools.mk81
-rw-r--r--build-aux/no-builtin-variables.mk11
4 files changed, 216 insertions, 0 deletions
diff --git a/build-aux/Makefile.each.head/20-libretools.mk b/build-aux/Makefile.each.head/20-libretools.mk
new file mode 100644
index 0000000..90e9bda
--- /dev/null
+++ b/build-aux/Makefile.each.head/20-libretools.mk
@@ -0,0 +1,35 @@
+pkgconfdir = $(sysconfdir)/libretools.d
+pkgdocdir = $(docdir)/libretools
+pkglibexecdir = $(libexecdir)/libretools
+
+# Detect things about the directory we're in ####################################
+
+srcfiles-ignore/$(srcdir) = $(addsuffix /%,$(at.subdirs/$(@D)))
+
+ifeq ($(wildcard $(topsrcdir)/.git),)
+include $(srcdir)/.srcfiles.mk
+else
+$(srcdir)/.srcfiles.mk: FORCE
+ @echo srcfiles = $(filter-out $(srcfiles-ignore/$(@D)),$(shell cd $(@D) && git ls-files)) | $(WRITE_IFCHANGED) $@
+-include $(srcdir)/.srcfiles.mk
+endif
+
+detect-ignore =
+detect-ignore-exec =
+detect-ignore-conf =
+detect-ignore-ronn =
+detect-ignore-md = HACKING.md
+detect-ignore-sh =
+
+devtools-files =
+
+libretools-srcs = $(detect-all)
+libretools-mans = $(patsubst %.ronn,%,$(detect-ronn))
+libretools-bins = $(detect-exec)
+libretools-libexecs =
+libretools-libs = $(detect-sh)
+libretools-docs = $(detect-md) $(detect-ronn)
+libretools-confs = $(detect-conf)
+
+libretools-files = $(libretools-mans) $(libretools-bins) $(libretools-libexecs) $(libretools-libs) $(libretools-docs) $(libretools-confs)
+pots = $(libretools-bins) $(libretools-libexecs) $(libretools-libs)
diff --git a/build-aux/Makefile.each.tail/20-libretools.mk b/build-aux/Makefile.each.tail/20-libretools.mk
new file mode 100644
index 0000000..0b74d41
--- /dev/null
+++ b/build-aux/Makefile.each.tail/20-libretools.mk
@@ -0,0 +1,89 @@
+# Copyright (C) 2015, 2016 Luke Shumaker
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ifneq ($(sort $(wildcard $(addprefix $(srcdir)/,$(devtools-files)))),$(sort $(addprefix $(srcdir)/,$(devtools-files))))
+ifeq ($(wildcard $(devtoolsdir)/),)
+$(error config.mk:devtoolsdir points to a non-existant directory: $(devtoolsdir))
+endif
+endif
+
+std.src_files += $(libretools-srcs)
+std.gen_files += .srcfiles.mk $(devtools-files)
+std.out_files += $(filter-out $(std.src_files) $(std.gen_files),$(libretools-files)) \
+ $(if $(pots),everything.pot)
+std.sys_files += $(addprefix $(bindir)/,$(libretools-bins)) \
+ $(addprefix $(pkgconfdir)/,$(libretools-confs)) \
+ $(addprefix $(pkglibexecdir)/,$(libretools-libexecs) $(libretools-libs)) \
+ $(addprefix $(pkgdocdir)/,$(libretools-docs)) \
+ $(addprefix $(mandir)/man1/,$(filter %.1,$(libretools-mans))) \
+ $(addprefix $(mandir)/man2/,$(filter %.2,$(libretools-mans))) \
+ $(addprefix $(mandir)/man3/,$(filter %.3,$(libretools-mans))) \
+ $(addprefix $(mandir)/man4/,$(filter %.4,$(libretools-mans))) \
+ $(addprefix $(mandir)/man5/,$(filter %.5,$(libretools-mans))) \
+ $(addprefix $(mandir)/man6/,$(filter %.6,$(libretools-mans))) \
+ $(addprefix $(mandir)/man7/,$(filter %.7,$(libretools-mans))) \
+ $(addprefix $(mandir)/man8/,$(filter %.8,$(libretools-mans)))
+std.clean_files += *.pot *.ugly *.rej *.orig .tmp*
+
+exec_$(outdir) := $(exec_$(outdir)) $(libretools-bins) $(libretools-libexecs)
+
+_is_executable = $(filter $(exec_$(@D)),$(@F))
+
+$(srcdir)/%.in: $(devtoolsdir)/%.in
+ cp -T '$<' '$@'
+$(srcdir)/%.in: $(devtoolsdir)/lib/%
+ cp -T '$<' '$@'
+$(outdir)/%: $(srcdir)/%.in
+ @echo 'EDIT < $< > $@'; $(edit) < '$<' | install -T -m$(if $(_is_executable),755,644) /dev/stdin '$@'
+$(outdir)/%: $(srcdir)/%.ronn
+ ronn --roff $(RONNFLAGS) < '$<' > '$@'
+$(outdir)/%.html: $(srcdir)/%.ronn
+ ronn --html $(RONNFLAGS) < '$<' > '$@'
+$(outdir)/%.pot: $(outdir)/% $(topsrcdir)/src/lib/librexgettext
+ $(topsrcdir)/src/lib/librexgettext $(LIBREXGETTEXT_FLAGS) '$<' > '$@'
+$(outdir)/%.pot: $(srcdir)/% $(topsrcdir)/src/lib/librexgettext
+ $(topsrcdir)/src/lib/librexgettext $(LIBREXGETTEXT_FLAGS) '$<' > '$@'
+$(outdir)/everything.pot: $(addprefix $(outdir)/,$(addsuffix .pot,$(pots)))
+ cat $^ | $(pofmt) > '$@'
+
+# If we have a .patch file, the flow is:
+# $(devtoolsdir)/%.in -> %.in + %.patch -> %.ugly -> %
+_do_patch = $(filter $(patsubst %.patch,%,$(filter %.patch,$(detect-all))),$(patsubst %.in,%,$(devtools-files)))
+$(outdir)/%.ugly: $(srcdir)/%.in $(srcdir)/%.patch
+ cp -T $< $@
+ patch $@ $(<D)/$*.patch
+$(sort $(addprefix $(outdir)/,$(_do_patch))): $(outdir)/%: $(outdir)/%.ugly
+ @echo 'EDIT < $< > $@'; $(edit) < '$<' | install -T -m$(if $(_is_executable),755,644) /dev/stdin '$@'
+ @echo 'INDENT $@'; $(call indent,$@)
+
+$(DESTDIR)$(pkgconfdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(pkgdocdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(mandir)/man1/%.1: $(outdir)/%.1; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(mandir)/man2/%.2: $(outdir)/%.2; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(mandir)/man3/%.3: $(outdir)/%.3; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(mandir)/man4/%.4: $(outdir)/%.4; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(mandir)/man5/%.5: $(outdir)/%.5; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(mandir)/man6/%.6: $(outdir)/%.6; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(mandir)/man7/%.7: $(outdir)/%.7; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(mandir)/man8/%.8: $(outdir)/%.8; install -T -Dm644 '$<' '$@'
+$(DESTDIR)$(pkglibexecdir)/%: $(outdir)/% ; mkdir -p '$(@D)' && cp -T '$<' '$@'
+$(DESTDIR)$(bindir)/% : $(outdir)/% ; install -T -Dm755 '$<' '$@'
+# Repeat the last two rules again with explicit targets because
+# otherwise it would try to do src/xbs->/bin/xbs instead of
+# src/xbs/xbs->/bin/xbs
+ifneq ($(filter $(notdir $(outdir)),$(libretools-files)),)
+$(DESTDIR)$(pkglibexecdir)/$(notdir $(outdir)): $(DESTDIR)$(pkglibexecdir)/%: $(outdir)/% ; mkdir -p '$(@D)' && cp -T '$<' '$@'
+$(DESTDIR)$(bindir)/$(notdir $(outdir)): $(DESTDIR)$(bindir)/% : $(outdir)/% ; install -T -Dm755 '$<' '$@'
+endif
diff --git a/build-aux/Makefile.once.head/20-libretools.mk b/build-aux/Makefile.once.head/20-libretools.mk
new file mode 100644
index 0000000..48964d9
--- /dev/null
+++ b/build-aux/Makefile.once.head/20-libretools.mk
@@ -0,0 +1,81 @@
+# Copyright (C) 2015 Luke Shumaker
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# Configure how Make works
+MAKEFLAGS += --no-builtin-rules --no-builtin-variables
+.SECONDARY:
+.DELETE_ON_ERROR:
+
+.PHONY: FORCE
+
+# Magic for tracking variables that affect files. If a file changes
+# based on a variable, just stick $(var)VARNAME as a dependency.
+var = $(call at.path,$(topoutdir)/.var.)
+$(var)%: FORCE
+ @printf '%s' '$($*)' | $(WRITE_IFCHANGED) $@
+
+# Usage: <INPUT $(edit) >OUTPUT
+# Expand m4_include macros to use librelib
+# This is used when using sources grabbed from devtools
+# Magic for doing @variable@ replacement in files
+edit = sed \
+ -e 's|^\#!\s*/bin/bash|\#!/usr/bin/env bash|' \
+ -e 's|m4_include(lib/\(.*\))|. "$$(librelib \1)"|' \
+ $(foreach v,$(patsubst $(var)%,%,$(filter $(var)%,$^)), -e 's|@$(v)@|$($(v))|g' )
+
+# Usage: $(call indent,FILENAME)
+# Command to auto-indent a file.
+indent = emacs --batch $1 \
+ --eval '(setq make-backup-files nil)' \
+ --eval '(setq sh-basic-offset 8)' \
+ --eval '(defun sh-smie-sh-rules--fix (args) "fix bug in Emacs 24 sh-script.el" (if (equal args (list :after "then")) (list :after "if") args))' \
+ --eval "(advice-add 'sh-smie-sh-rules :filter-args \#'sh-smie-sh-rules--fix)" \
+ --eval '(indent-region (point-min) (point-max) nil)' \
+ -f save-buffer &>/dev/null
+
+# Usage <INPUT $(pofmt) >OUTPUT
+# Normalize a .po(t) file
+pofmt = msguniq -Fi --to-code=UTF-8
+
+# It's easy to think of these as "each" variables, but because they
+# will be evaluated on demand, only std.src_files needs to be "each".
+detect-all = $(filter-out $(detect-ignore) ,$(srcfiles))
+detect-exec = $(filter-out $(detect-ignore-exec),$(patsubst $(srcdir)/%,%,$(shell find $(addprefix $(srcdir)/,$(detect-all)) -executable)))
+detect-conf = $(filter-out $(detect-ignore-conf),$(filter %.conf ,$(detect-all)))
+detect-ronn = $(filter-out $(detect-ignore-ronn),$(filter %.ronn ,$(detect-all)))
+detect-md = $(filter-out $(detect-ignore-md) ,$(filter %.ronn %.md,$(detect-all)))
+detect-sh = $(filter-out $(detect-ignore-sh) ,$(filter %.sh ,$(detect-all)))
+
+ifeq ($(wildcard $(topsrcdir)/.git),)
+include $(topsrcdir)/.srcversion-libretools.mk
+else
+$(topsrcdir)/.srcversion-libretools.mk: FORCE
+ @{ \
+ echo LIBRETOOLS_VERSION = $(patsubst v%,%,$(shell cd $(topsrcdir) && git describe --tags)); \
+ echo LIBRETOOLS_COMMIT = $(shell cd $(topsrcdir) && git rev-parse HEAD); \
+ :; } | $(WRITE_IFCHANGED) $@
+-include $(topsrcdir)/.srcversion-libretools.mk
+endif
+
+ifeq ($(wildcard $(devtoolsdir)/.git),)
+include $(topsrcdir)/.srcversion-devtools.mk
+else
+$(topsrcdir)/.srcversion-devtools.mk: FORCE
+ @{ \
+ echo DEVTOOLS_VERSION = $(patsubst libretools-%,%,$(shell cd $(devtoolsdir) && git describe --tags)); \
+ echo DEVTOOLS_COMMIT = $(shell cd $(devtoolsdir) && git rev-parse HEAD); \
+ :; } | $(WRITE_IFCHANGED) $@
+-include $(topsrcdir)/.srcversion-devtools.mk
+endif
diff --git a/build-aux/no-builtin-variables.mk b/build-aux/no-builtin-variables.mk
new file mode 100644
index 0000000..c236c73
--- /dev/null
+++ b/build-aux/no-builtin-variables.mk
@@ -0,0 +1,11 @@
+MAKEFLAGS += --no-builtin-variables
+
+# This version is more correct, but is slower:
+# $(foreach v,$(shell bash -c 'comm -23 <(env -i $(MAKE) -f - <<<"\$$(info \$$(.VARIABLES))all:"|sed "s/ /\n/g"|sort) <(env -i $(MAKE) -R -f - <<<"\$$(info \$$(.VARIABLES))all:"|sed "s/ /\n/g"|sort)'),
+# $(if $(filter default,$(origin $v)),$(eval undefine $v)))
+
+_default_variables = $(foreach v,$(.VARIABLES),$(if $(filter default,$(origin $v)),$v))
+$(foreach v,$(filter-out .% MAKE% SUFFIXES,$(_default_variables))\
+ $(filter .LIBPATTERNS MAKEINFO,$(_default_variables)),\
+ $(eval undefine $v))
+undefine _default_variables