summaryrefslogtreecommitdiff
path: root/common.each.head.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
commit7e704d7ac997387341e920e1757c24cac0efe5e9 (patch)
treea9f30eabaaad5496397a91053d3e03bab1ea57e4 /common.each.head.mk
parent7785a72495e3eb0ea826b41720c241f58a15b601 (diff)
Refactor the build system. Avoid recursive make.
This looks like a lot, but more things should "just work". We have `make dist` now!
Diffstat (limited to 'common.each.head.mk')
-rw-r--r--common.each.head.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/common.each.head.mk b/common.each.head.mk
new file mode 100644
index 0000000..8a2a68d
--- /dev/null
+++ b/common.each.head.mk
@@ -0,0 +1,32 @@
+pkgconfdir = $(sysconfdir)/libretools.d
+pkgdocdir = $(docdir)/libretools
+pkglibexecdir = $(libexecdir)/libretools
+
+# Detect things about the directory we're in ####################################
+
+ifeq ($(wildcard $(topsrcdir)/.git),)
+include $(srcdir)/.srcfiles.mk
+else
+$(srcdir)/.srcfiles.mk: FORCE
+ @echo am_src_files = $(filter-out $(addsuffix /%,$(_am_subdirs/$(@D))),$(shell cd $(@D) && git ls-files)) | $(write-ifchanged) $@
+-include $(srcdir)/.srcfiles.mk
+endif
+
+detect-ignore =
+detect-ignore-exec =
+detect-ignore-conf =
+detect-ignore-ronn =
+detect-ignore-md = HACKING.md
+detect-ignore-sh =
+
+devtools-files =
+
+install-mans = $(patsubst %.ronn,%,$(detect-ronn))
+install-bins = $(detect-exec)
+install-libexecs =
+install-libs = $(detect-sh)
+install-docs = $(detect-md) $(detect-ronn)
+install-confs = $(detect-conf)
+
+install-files = $(install-mans) $(install-bins) $(install-libexecs) $(install-libs) $(install-docs) $(install-confs)
+pots = $(install-bins) $(install-libexecs) $(install-libs)