summaryrefslogtreecommitdiff
path: root/common.mk
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-03-21 14:39:39 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-03-21 14:39:39 -0400
commit69bdd4ea9459209fe1a7768344b1975bea0a0fd0 (patch)
tree3d80f9591816387d155cd5042646df5d96efe9c1 /common.mk
parentd25f30f25ce61367c81133c9cd01fe3169d8f6c0 (diff)
Fix a small bug in common.mk
Diffstat (limited to 'common.mk')
-rw-r--r--common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/common.mk b/common.mk
index ea0c588..ec8135f 100644
--- a/common.mk
+++ b/common.mk
@@ -94,7 +94,7 @@ _do_patch = $(filter $(patsubst %.patch,%,$(wildcard *.patch)),$(patsubst %.in,%
%.ugly: %.in %.patch Makefile
cp $*.in $@
@echo 'PATCH $@ $*.patch'; patch $@ $*.patch
-$(_do_patch): %: %.ugly Makefile
+$(sort $(_do_patch)): %: %.ugly Makefile
@echo 'EDIT < $< > $@'; $(edit) <'$<' >'$@'
@echo 'INDENT $@'; $(call indent,$@)
$(if $(filter-out %.sh,$@),chmod 755 "$@")