summaryrefslogtreecommitdiff
path: root/common.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2014-06-29 22:47:26 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2014-06-29 22:47:26 -0400
commit5a84f3c84a1f3275f5b3ab51b1cf90327f52b9b2 (patch)
treeb6bf66c7823129ff51ad64eae20881e5e9c47cd6 /common.mk
parent89ec7c1ab9310c37219e52fcf6dbd4eaa12ffe7e (diff)
common.mk: pull $(docdir)/libretools into $(pkgdocdir)testing-20140630
Diffstat (limited to 'common.mk')
-rw-r--r--common.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/common.mk b/common.mk
index a05e0c6..0bcc2b8 100644
--- a/common.mk
+++ b/common.mk
@@ -1,6 +1,7 @@
topdir := $(dir $(lastword $(MAKEFILE_LIST)))
include $(topdir)/config.mk
-pkgconfdir ?= $(sysconfdir)/libretools.d
+pkgconfdir ?= $(sysconfdir)/libretools.d
+pkgdocdir ?= $(docdir)/libretools
pkglibexecdir ?= $(libexecdir)/libretools
# Misc variables for use in recipes ############################################
@@ -125,7 +126,7 @@ $(sort $(addprefix $(DESTDIR)$(pkglibexecdir)/,$(libs))): $(DESTDIR)$(pkglibexec
# everything else
$(DESTDIR)$(pkgconfdir)/%: %
install -Dm644 '$<' '$@'
-$(DESTDIR)$(docdir)/libretools/%: %
+$(DESTDIR)$(pkgdocdir)/%: %
install -Dm644 '$<' '$@'
$(DESTDIR)$(mandir)/man1/%.1: %.1
install -Dm644 '$<' '$@'